Raptor Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I bought my raptor 660 about a month ago, third ride it started having problems starting and idling(humming then cranks when i jumped on it), when i checked the battery it was melting on the positive side, i put a new battery in it and it started but still seemed like the starter had problems grabbing so i put a new starter in it because i assumed that was my issue, it started once right after i installed it but the second try it wouldnt go and hasnt started since yesterday even if i jump on it and just makes a humming noise when i press the start button. What could be my problem? I really need help.
 

·
Master of the Electron
Joined
·
16,110 Posts
humming then cranks when i jumped on it,,,
... hasnt started since yesterday even if i jump on it and just makes a humming noise when i press the start button. What could be my problem? I really need help.
I fail to understand what 'jumping on it' means nor what it has to do with the starting process, Can you be MUCH more detailed please?

AND. Is the 'humming noise' a buzzing that comes from the starter solenoid? This is usually due to bad or discharged battery, bad/corroded battery cables, or seizing starter or engine. With new battery and starter I'd suggest the likely culprit is the battery cables are corroded in the copper near the terminals. Use a pair of jumper cables to jump around the existing battery cable - if the problem goes away you know which cable is bad.
 
1 - 2 of 2 Posts
Top