Raptor Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
so i can ride and stuff for about an hour but then it starts to bog and sputter and backfire. does anyone know how to clear it up. i cleaned the carb and changed the spark plug but it still does it. does have a hmf pipe if that has to do anything with it
 

·
Registered
Joined
·
4,055 Posts
Is it a slip on it full exhaust? Is the airbox lid on or off? What size jets are in the carb?

Sent from my SM-G975U using Tapatalk
 

·
I may be getting older, but I refuse to grow up!
Joined
·
11,188 Posts
Check the gas cap vent. Air in thru the breather hose??
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
Is it a slip on it full exhaust? Is the airbox lid on or off? What size jets are in the carb?

Sent from my SM-G975U using Tapatalk
it has a slip on exhaust and no the lid is on but was hearing stuff about taking of the snorkel part. so planned on doing that today. and it just has the oem jets
 

·
Registered
Joined
·
2,051 Posts
Check the gas cap vent. Air in thru the breather hose??
Dont ignore this! Could be the problem. If its not, then take the fuel line off the petcock and drain fuel back into your gas can looking for a nice steady flow. Bad fuel cap vent or bad petcock can cause this.
it has a slip on exhaust and no the lid is on but was hearing stuff about taking of the snorkel part. so planned on doing that today. and it just has the oem jets
If you gut the snorkel you WILL have to change jets

Sent from my SM-G920V using Tapatalk
 
  • Like
Reactions: DEZPERADO
1 - 5 of 5 Posts
Top