Raptor Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4,097 Posts
Discussion Starter #1
My neutral light is staying on in every gear including reverse. I assume a wire has either broke, come unplugged or needs connections cleaned. It hasn't always been on. When I first got the bike the reverse light would come on when in reverse and now it doesn't. The PO grounded somethin by the shifter. I assume its the reverse limiter since it doesn't cut out in reverse. Will it hurt anything to ride it with the neutral light on? Has anyone encountered this? If so how did you fix it? Thanks for the help. :beer:
 

·
Master of the Electron
Joined
·
15,074 Posts
Neutral switch has failed or light blue wire is pinched (shorted) to the frame somewhere - look under the seat around the battery box- wires get abused here. OR

WOn't hurt, it'll just start in any gear without pulling the clutch.
 

·
Registered
Joined
·
4,097 Posts
Discussion Starter #3
thank you QM. i looked like a spider monkey crawling all over my bike trying to find a broken wire. now that i know where to look i will try again. where is the neutral switch at? does the factory service manual have a wiring diagram of the bike? i love wiring diagrams.
 

·
Master of the Electron
Joined
·
15,074 Posts
Yes the last page of the manual is the wiring diagram - download it free from 660 maintenance section in the stickies at the top.

The switch is in front of and below the output sprocket - light blue wire is screwed to it, it's right next to the reverse switch (green/white wire).
 

·
Registered
Joined
·
4,097 Posts
Discussion Starter #5
ah. probably should have gathered that from your previous post. i did just put a new chain and sprockets on it so i wonder if i somehow ripped it out.. ive tried to download the manual a few times with no luck. ill have to try again, i really want that diagram
 

·
Registered
Joined
·
4,097 Posts
Discussion Starter #6
So just to update, there was nothing wrong with the wires. My tabs broke off my case and using J00F150's idea I made brackets using the chain rollers. On the bottom bracket I put a washer between the bracket and tab that broke off the case. The washer was contacing the neutral switch and the bracket. Took the washer off and problem solved. Thanks again for your help QM.
 

·
Master of the Electron
Joined
·
15,074 Posts
First time I've heard of a short THERE, lol... glad it was easy.
 

·
Registered
Joined
·
4,097 Posts
Discussion Starter #8
Yeah me too. I should've checked for clearance before I tightened everything up. Lesson learned for the next time.
 
1 - 8 of 8 Posts
Top