Raptor Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey everyone, this is my first time posting here and not sure if this has be covered in another post yet but here’s what’s happening.

I recently got a 07 raptor 350 SE2. It seems like my carb is backfiring but not actually backfiring out the exhaust if that makes sense. While idling every few second I hear a pop and the carb shakes a bit. The idle is not right either. I pulled the carb apart and cleaned everything jets included really good but same issue. Not sure where to go from here. The 350 is all stock with stock jets. Any help is appreciated. Thanks
 

·
Registered
Joined
·
11 Posts
Do you have stock exhaust? If so is the spark arrestor in it? I have an 08 350 and when i bought it, it did not have the arrestor and ran fine. I installed a oem arrestor cause trails by me they are mandatory. Once installed the raptor ran like crap and stalled all the time. I took to certified yamaha shop and they adjusted carb and now runs like new
 

·
Registered
Joined
·
6 Posts
I had a similar problem. Mine wouldn’t rev past ab 1/4 throttle but would idle decent w some carb backfire. I ended up having to buy a new carb. It had a $20 amazon carb on it and I doubt it was jetted right. Anyways the new carb fixed the problem right away
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
The exhaust it stock, I believe the spark arrest is still in it but I’ll double check and let you know. Thanks
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Yes the spare arrestor is still in the stock exhaust pipe. Any recommendations on where to get a used carb in good shape or am I better off buying one brand new to $350. Any input is appreciated
 
1 - 7 of 7 Posts
Top