Raptor Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
468 Posts
Discussion Starter #1
I have been running the NGK Iridium NGK R CR8E. Has anybody noticed their bike running more hot since they changed? My fan is running much more often since the switch and if anything the temps have been slightly cooler. I didn't know if this is normal.

Craig,
 

·
Registered
Joined
·
3,586 Posts
nope....I thought my machine ran better. My fan never kicks on
 

·
Registered
Joined
·
841 Posts
Mine runs better also, usually only hear my fan on real hot days
 

·
Registered
Joined
·
226 Posts
Nothin' hear....the sparkplug seems to be good
 

·
Registered
Joined
·
468 Posts
Discussion Starter #5
Mine works fine. Seems to have smoothed out the idle a bit and it is a little more snappy but my fan come on quite a bit now and it did not before. The only change was the plug. It might just be me! You know overanalytical. Thanks for the responses guys.

Craig,
 

·
Registered
Joined
·
882 Posts
i just switched to the ngk and am very pleased except for my rpms are not showing on my tach???i switched plugs back and poof..rpms show up...what the heck is causing this?
 

·
Registered
Joined
·
610 Posts
Talljess said:
i just switched to the ngk and am very pleased except for my rpms are not showing on my tach???i switched plugs back and poof..rpms show up...what the heck is causing this?
You have got to be freakin' kidding me :wtf:
I'm almost laughing, but this Vapor crap aint funny.
 

·
Registered
Joined
·
584 Posts
Mine runs great too, fan never kicks on.
 

·
Registered
Joined
·
882 Posts
fixed the problem..the little connector wire(white connector) that goes to the vapor had a loose connection..replaced it and works great again..just a strange coincidence..also had to richin the map up 2% to make her run better..I suppose i will go with a colder iridium plug,,seems like she runs hotter..also dont wanna detonate when nos kicks on
 
1 - 9 of 9 Posts
Top