Raptor Forum banner

No oil pressure

371 Views 4 Replies 2 Participants Last post by  Brando513
I'm not getting any oil to the head and was wondering if the check valve in the case could cause low pressure if it were bad?
1 - 5 of 5 Posts
Yes, if that ball/seal/spring is not correctly installed in the clutch cover you will lose oil pressure. Also sometimes the clutch cover gasket can cover passages.
Have you had clutch cover off recently?
Yes, if that ball/seal/spring is not correctly installed in the clutch cover you will lose oil pressure. Also sometimes the clutch cover gasket can cover passages.
Have you had clutch cover off recently?
Yes about 2 months ago the wrist pin seized causing the engine to lock up so I tore down the whole top end of the motor replace the piston wrist pin and made sure that the rod the little end of the rod was okay put it all back together and put clutches in it and now all now it don't have no oil pressure to the head or pretty much anywhere for that obviously that's why the wrist pin locked up lack of oil. I've checked oil pump it's fine there's no blockages the screen in the tank ain't blocked up the screen in the bottom of the motor ain't blocked up I'm just I have no idea man by the way thanks in advance for your reply
Yes about 2 months ago the wrist pin seized causing the engine to lock up so I tore down the whole top end of the motor replace the piston wrist pin and made sure that the rod the little end of the rod was okay put it all back together and put clutches in it and now all now it don't have no oil pressure to the head or pretty much anywhere for that obviously that's why the wrist pin locked up lack of oil. I've checked oil pump it's fine there's no blockages the screen in the tank ain't blocked up the screen in the bottom of the motor ain't blocked up I'm just I have no idea man by the way thanks in advance for your reply
Are you getting oil to the filter?
Yes about 2 months ago the wrist pin seized causing the engine to lock up so I tore down the whole top end of the motor replace the piston wrist pin and made sure that the rod the little end of the rod was okay put it all back together and put clutches in it and now all now it don't have no oil pressure to the head or pretty much anywhere for that obviously that's why the wrist pin locked up lack of oil. I've checked oil pump it's fine there's no blockages the scree
Are you getting oil to the filter?
No
1 - 5 of 5 Posts
Top