Raptor Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2008 raptor 250 i have no spark. I replaced stator,cdi,coil and wire and i also replaced the regulator rectifier can some one help me
 

·
Registered
Joined
·
108 Posts
Have you pulled the sheathing off the harness to look for breaks? Checked for corrosion at all connections and at the kill switch on the handlebars? Get the manual from this site and look at the end of it. There are many wiring diagrams. Follow the wires for the starting circuit. I would do that before you spend any more money replacing stuff.
 

·
Registered
Joined
·
1,739 Posts
Did you replace the sparkplug?
Sometimes it's just something simple.
And, have you tested the new parts?
You can get new bad parts.
 

·
Registered
Joined
·
1,739 Posts
Have you pulled the sheathing off the harness to look for breaks? Checked for corrosion at all connections and at the kill switch on the handlebars? Get the manual from this site and look at the end of it. There are many wiring diagrams. Follow the wires for the starting circuit. I would do that before you spend any more money replacing stuff.
+1
Start buttons are bad about corrosion too, and it only takes a very small amount to prevent a connection.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
+1
Start buttons are bad about corrosion too, and it only takes a very small amount to prevent a connection.
Yea i pulld the sheathing off ans no breaks in the wire i found corrosion at the starter the relay i will check that
 
1 - 6 of 6 Posts
Top