Raptor Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
1,743 Posts
Discussion Starter #1 (Edited)
I replaced the thumb throttle with an aftermarket aluminum one, with a housing that has more clearance so the brake MC can slide closer to that throttle than the stock one, for better shorty lever position.
I put the new thumb throttle on, with the key off, simple enough, cranked to test the cable position, and no start with a check engine light.
Could I have possibly upset the tps?
I don't see how, especially with the key off, unless somehow the extra retraction of the cable when it's disconnected from the thumb lever could throw it off?
Is there a way to diagnose the 700's e.f.i?, as I havn't looked into any of that yet, but I am going to start reading the manual now. Isn't there a diagnostic plug under the seat?
I was riding earlier and everything was fine.
It is firing as I put the plug(which looks good) in the cap on the exhaust heat sheild and pushed the starter, bright blue spark.
I can hear the fuel pump prime when I turn the key on.
Yes, it has gas in it, lol.
I can't find any loose connections.
What did I do??
 

·
Registered
Joined
·
1,743 Posts
Discussion Starter #4
I also ordered this, as it's the only thing that I can find for a diagnostic tool.
It's cheap enough to try.

Anyone know a better way?
Screenshot_20201023-221721_eBay.jpg
 

·
Registered
Joined
·
1,743 Posts
Discussion Starter #5
I can't find any info on the fuel pump recall either.
I will have to troubleshoot the pump by the manual.
I would think that since I can hear it prime, it should sputter or try to start, but nothing, seems like it's getting no fuel.
It has died 3 times in the last week a few seconds after it starts up, but immediately fires and runs fine after.
So maybe it is the pump??
We'll see.
 

·
I may be getting older, but I refuse to grow up!
Joined
·
11,690 Posts
You have a check engine light?
Any codes??
 

·
I may be getting older, but I refuse to grow up!
Joined
·
11,690 Posts
Try some starter fluid.

Have you installed a tuner yet? Disconnect it.

Check the timing marks, and verify valve clearance, especially the intake.

Will it pull start?

Battery at least 13+ volts.
 

·
Registered
Joined
·
1,743 Posts
Discussion Starter #8
You have a check engine light?
Any codes??
Yes, check engine light comes on when I push the starter.
I have nothing to check codes with.
No pcv5 or equivalent has been installed, so no problems there.
Only electrical mods are the Vapor, early-on fan stat, and battery tender.
Vapor fuse is good.
Sounds like it's not getting gas, even though the fuel pump primes.
Battery is good.
If the timing or valves are off(I'm 99.9% sure they are fine), then the pos can go back under a lemon law.
I'll test the fuel pump by the manual later today, and order one if it is bad.
Dealer I bought if from fix it under warranty? Sure...but that's a 13 hr+ round trip, gas will cost more than the pump.
Let a local dealer fix it under warranty? Lmao, none of those clowns will ever touch it.
Even though I haven't properly diagnosed it yet, my money is on the fuel pump.
BS Yamaha...BS!
 

·
I may be getting older, but I refuse to grow up!
Joined
·
11,690 Posts
I have a pump. Just pay shipping.
 

·
I may be getting older, but I refuse to grow up!
Joined
·
11,690 Posts
Codes are read by blinking lights on the dash.
 
  • Like
Reactions: Sixpack577

·
Registered
Joined
·
2,304 Posts
If you replace it, ive heard the quantum fuel pump is the cheapest and most reliable replacement for us. At $70, Ive even thought about just buying one to have on hand in case mine goes out. FYI, they come with a lifetime free replacement warranty

Sent from my SM-G981U using Tapatalk
 

·
Registered
Joined
·
2,304 Posts
  • Like
Reactions: Sixpack577

·
Registered
Joined
·
1,743 Posts
Discussion Starter #13
If you replace it, ive heard the quantum fuel pump is the cheapest and most reliable replacement for us. At $70, Ive even thought about just buying one to have on hand in case mine goes out. FYI, they come with a lifetime free replacement warranty

Sent from my SM-G981U using Tapatalk
Thanks, I was looking at those.
 

·
Registered
Joined
·
1,743 Posts
Discussion Starter #16
Fixed!
The problem was fortunately just something stupid...me.
Working on things late and tired again.
Last night I did not notice that adding the supplied(but not required) lock ring, kept the throttle from completely closing.
So it apparently will not start, or has hard starts(as I got it to fire and idle way high after holding the starter for about 20 seconds), if the throttle is opened enough.
Everything now works normally as before, and the new throttle gave me the clearance that I was looking for.
I am still leary of the fuel pump, given the starting hiccups I've had prior to this issue, so time will tell.
Note to self, for the umpteenth time...know when you are too tired and walk away.
If I had installed the new throttle this morning instead, I would have never started this thread.
Thank you guys both too, really,
I appreciate the advice and offers!
20201024_123437.jpg
 

·
I may be getting older, but I refuse to grow up!
Joined
·
11,690 Posts
Stuff happens!!
My boss would tell me "The guys need to work 10 hour days". OK, will do. Then he wanted "12 hour days". Production fell off and mistakes had to be corrected the next day. I'm all for 8hour days, with occasional overtime, but not forced!!
I used to tell them I had to go to my "other job". What's that they asked? My other job was "Husband, father, and relaxer!
 
1 - 17 of 17 Posts
Top