Raptor Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
68 Posts
Discussion Starter #1
i have a 02 660 that i bought from a buddy of mine that needed a new head put on it....got a head and installed and was getting everything buttoned up when i went to change the oil i pulled the plug on the crank case to find no oil in it....pulled the plug in the tank and it was full.....replaced both plugs and pulled the oil filter and it appeared to be new so i was thinking that the oil had been drained per it was torn down when i bought it....but then i got to thinking that the tank was full....so i refilled the tank and run it for a few seconds per the book and then pulled the drain on the crank case again to find that there was still very little if any oil there....pulled the line off next to the drainplug and oil came out....pulled the oil filter to find it still looked new and dry.....any ideas on what the problem might be....seemed to run fine without any noises for the few second i ran it but dont want to trash the motor with no oil...? any help would be of great value
 

·
Super Moderator
Joined
·
17,058 Posts
could be a bad oil pump, but first I'd pull the oil line off the bottom of the tank. There's a screen in there that can get plugged up and could use a good cleaning.

Where you'll want to test the oil flow is the line going to the top of the head on the right hand side (brake levers side) of the bike. If you can't get oil pumping there you may need to clean out the scavenger or replace the pump all together.
 

·
I am unique
Joined
·
22,621 Posts
To add, there is a small plug on the right hand side of the head in the end of the cam cover, loosen this plug when you start the engine, oil should come out of this plug within 30 seconds of startup..............
 

·
Registered
Joined
·
68 Posts
Discussion Starter #4
well looks like im going to need to pull the oil pump out of it.....there is no oil flowing anywhere on this quad....so i will be pulling the cover off of it this week sometime and pulling the oil pump out of it for replacement.....:mad:
 

·
Registered
Joined
·
68 Posts
Discussion Starter #5
im assuming that if i want to check the oil pump pickup that i would have to split the case to do this.....if so i think ill just blow some air in it to make sure it isnt plugged....is this a problem?
 

·
Registered
Joined
·
131 Posts
my initial though was a clogged feed line, but the one on bottom is the feed line. if you pulled the bottom line and oil flows through the line, i'd have to go with general concensus and say your oil pump isn't working, which is probably why it needed a new head in the first place...
 
1 - 6 of 6 Posts
Top