Raptor Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
I have a 07' Raptor 700R and the problem im having is that my oil resivoir is overflowing when i check oil. so i drained some out and when i ran it for a little bit and shut off to check it again it was overflowing again it smells like there could be fuel going into it. i took out injector and cleaned with lucus cleaner and ran some lucus through fuel and seemed to quite for about a month. i just went to go ride today and i checked the oil and its doing it again. any ideas. "mechanically inclined"
 

·
Registered
Joined
·
2,183 Posts
Did it just start doing it out of the blue? Or did you change the oil , do clutch work , ect.

This helps for us to be able to help you out.......:thumbsup:
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
run engine for about ten mins. and then let it sit for a few mins and i pull it out wipe it off and put back in with out screwing it in and on level ground!
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #6 ·
im not dumb when it comes to quads and dirt bikes i know how its done i have a raptor 660r , a kx 250, yz85, snowmobiles and polaris 700 4x4 and i have CLYMER maintenance books for all of them so i go by everything they wans specifically for that toy.
 

·
If it's too loud your too old
Joined
·
6,925 Posts
Pull the tank there is a finger screen on the line that comes out of the bottom of the tank sounds like it may be partially plugged.
 

·
If it's too loud your too old
Joined
·
6,925 Posts
im not dumb when it comes to quads and dirt bikes i know how its done i have a raptor 660r , a kx 250, yz85, snowmobiles and polaris 700 4x4 and i have CLYMER maintenance books for all of them so i go by everything they wans specifically for that toy.
I didn't say you were I was just checking so I didn't give you wrong info.:simmadown:
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #9 ·
i have checked screen on bottom of oil resivor and its clean. and the thing i dont get is the engine performs good and top end and everythings working like it should. and its not throwing any codes not check engine light on nothing. so i dont get it. like you take off dip stick and oil will run out of resivor. so it is letting fuel in some how. and its not milky or creamy or white so its not coolant or water. any other ideas
 

·
If you don't wreck, you don't ride
Joined
·
4,450 Posts
I thought a 700's would do this when warm, because of some differences in oil line return rates...Maybe wrong though
 

·
If it's too loud your too old
Joined
·
6,925 Posts
i have checked screen on bottom of oil resivor and its clean. and the thing i dont get is the engine performs good and top end and everythings working like it should. and its not throwing any codes not check engine light on nothing. so i dont get it. like you take off dip stick and oil will run out of resivor. so it is letting fuel in some how. and its not milky or creamy or white so its not coolant or water. any other ideas
The only sure way to tell is drain it and measure what comes out. Mine will do this sometimes but I have a aftermarket oil tank and I run 3qts. of oil cause the tank holds a extra qt. so I just chalked it up to that. I don't remember having this issue when I had the stock tank.
 

·
Ridin High.....
Joined
·
961 Posts
same issue. overflowing oil from CFM tank. overflowed after letting warm up, turn off, sit and then check. but then i waited an entire day and checked it with out warming up or anything it was right at FULL in the oil tank, no overflow.....weird. bigger tank and diffrent return rate on the oil lines causing this?
 

·
Cola Crew
Joined
·
1,368 Posts
same issue. overflowing oil from CFM tank. overflowed after letting warm up, turn off, sit and then check. but then i waited an entire day and checked it with out warming up or anything it was right at FULL in the oil tank, no overflow.....weird. bigger tank and diffrent return rate on the oil lines causing this?
same issue
My crank case vent tube was clogged and blow by was pushing the oil back to the tank.
The vent tube is not filtered air. I moved mine to the intake tube and I added a PCV valve.
 

·
Ridin High.....
Joined
·
961 Posts
same issue
My crank case vent tube was clogged and blow by was pushing the oil back to the tank.
The vent tube is not filtered air. I moved mine to the intake tube and I added a PCV valve.
can be that though. have a breather on my crank vent and an evac. i checked and its not clogged. hmmmm
 
1 - 18 of 18 Posts
Top