Raptor Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
I have 2004 raptor 660 i have pulled the two oil lines off the reservoir and they were fine so is my oil pump out or what ? anyhelp would be great thanks
 

·
I am unique
Joined
·
22,621 Posts
I have 2004 raptor 660 i have pulled the two oil lines off the reservoir and they were fine so is my oil pump out or what ? anyhelp would be great thanks
And why are you thinking that the oil is not returning to the reservoir.......
 

·
Registered
Joined
·
28 Posts
Discussion Starter #4
I had did an oil change a month before I went to little sahara and everything check out good it was returning to the reservoir and the right amount of oil was in it then when i got there i checked it after warming it up and there wasnt any oil in the reservoir then i added some and still nothing?
 

·
I am unique
Joined
·
22,621 Posts
I had did an oil change a month before I went to little sahara and everything check out good it was returning to the reservoir and the right amount of oil was in it then when i got there i checked it after warming it up and there wasnt any oil in the reservoir then i added some and still nothing?
The fact that the oil level remains low is an indication that oil is not returning to the oil reservoir, there are two oil pumps in the raptor engine, one of the pumps, the scavenger pump forces oil throughout the transmission and the excess goes to the oil reservoir, which in turn supplies oil to the engines second pump, this oil is filtered at the bottom of the reservoir before it leaves and this second pump, supplies oil to the engines head and crank, it is also filtered by the engines oil filter..........
 

·
I am unique
Joined
·
22,621 Posts
which pump do you think it is ? what else could be not allowing it to return to the resevoir?
Either the scavenger oil pump has a plugged sump or is defective...........
 
1 - 10 of 10 Posts
Top