Raptor Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2,017 Posts
Discussion Starter · #1 ·
Got back from a ride today. It felt good. I did my after ride inspection and checked the plug. Way LEAN.. Very white.... Checked the oil and it was an inch above the full mark. Proper procedure for checking it was done. Consistency still felt pretty good, was very dark though, darker than cofffee color. Had smell of gas. Had the TPS changed by dealer. Not sure what the deal is. But I am going to change the oil tonight and see again tommorrow.
 

·
Registered
Joined
·
113 Posts
Have you done a compretion check to see if you have a bad valve or rings?
 

·
Registered
Joined
·
2,017 Posts
Discussion Starter · #3 ·
Yeah when it was in for service they said the commpression was good.???????I am so confused....
 

·
Registered
Joined
·
49 Posts
I wouldnt worry about it dude. My oil seems high and smells like gas also. Seems like everyone has this problem and maybe we are just making a bigger deal out of it than it really is. If the bike is runnen good with no problems then dont sweat it.
 

·
Registered
Joined
·
113 Posts
An inch over high on the dip is not good, I 've been following your other thread on the gas in the oil, I find it strange that your plug indicates lean which meens your most likey not getting your gas smell in your oil thru the cylinder,the only other posible place would be your crank breather, does your air filter smell like gas? I'm getting ready to do all the major mods on my new 700 as soon as the engine breaks in so I've really been watching this subject.
 

·
Registered
Joined
·
2,017 Posts
Discussion Starter · #7 ·
Well here is the newest and hopefully the answer to my problems. I reversed the rappy into its spot in the garage today and checkeed the oil after a ride and what did I find. Dead on the full mark. My garage is almost level it has the slightest pitch toward the door and this threw it off that much. Just want you guys who were in the same boat to be sure the ground is level. Sweet no actual problems.
 

·
Registered
Joined
·
175 Posts
You may want to have the dealer check and see if the injector is leaking. If so that could cause the gas in the oil.

No matter what way you look at it, gas in the oil is bad. No two ways about it.
 

·
Registered
Joined
·
175 Posts
Machy said:
so does the oil lever rise when hot?

does the oil lever need to be checked when cold or hot?
Not trying to be a smart ass here, but just check it like the owners manual says too.

I would post what it says (word for word), but I do not have it with me.

It is a dry sump engine and needs to be checked carefully, or else you will get a false reading.
 

·
Registered
Joined
·
173 Posts
Oil expands when hot, so if your filling it with the engine cold its going to be over when you check it hot. Plus with the sump tank you have to circulate the oil ( run the engine) before checking to get an accurate reading. Read the manual.
 
1 - 11 of 11 Posts
Top