Raptor Forum banner
1 - 20 of 35 Posts
G

·
Discussion Starter · #1 ·
Jason from Rocket Factory knows how to treat customers. I got my barkers today and UPS must have played football with the package cause the pipes were sticking out of the box. After taking pics and opening it sure enough they were damaged.I called Jason and explained to him what was going on and he took care of me. Jason is the man. Thanks so much man :thumbsup:
 

·
Registered
Joined
·
2,480 Posts
Good to hear that they can help you out..... :thumbsup: I've had places tell me to deal with UPS.. :confused:

My Pro Circuit was sticking out of the box also, luckily the pipe was not damaged.. :unsure:
 

·
Registered
Joined
·
206 Posts
Anytime that I have had problems with shipped items, it has been with UPS.
Bastards :mad:
 
G

·
Discussion Starter · #4 ·
he told me that UPS takes over a month to do the claim, so thats a month without pipes. He took care of me,I'm so glad I bought from him and his map was right on. That thing rips now!! :thumbsup: Melodie from Barkers also deserves a medal for customer service. They rock also! :thumbsup:awesome product
 

·
Registered
Joined
·
2,480 Posts
I try to use FedEx Ground whenever possible now..... :thumbsup:
 

·
Registered
Joined
·
120 Posts
YAMAHA OF TROY sucks ass, i bought skid plates from them, the engine skid wasnt in but they still charged me for it and I waited 6 months to get it. I had to call every day for months, they suck. They didnt even apologize just said it was yamaha's fault. They shouldnt been advertising in on ebay then. Bastards! Oh yea and UPS does suck ass!
 

·
Registered
Joined
·
137 Posts
so whos the best people to ship with?i spoke to jasons worker yesterday (very helpfull guy) and said as i was the only one who payed via paypal out the group buy all the info was messed up,he took down all my details again so i have to call today and he will get my prices for postage and get my package sent out to me today with a tracking number, also im having the trinity air filter and adapter set up off them so they said they will program it all in for me :thumbsup:
After reading dizheftas report on ups im NOW paranoid :mad: that my exhaust will come all they way to the uk treated the same way as his exhaust was and will be a pain to send it back IF IT DOES can any one recommend a good service in the states that ship to the uk that are good at handling there packages thanx in advance
 

·
Registered
Joined
·
815 Posts
UPS will be fine.... I ship approximately 5-10 packages A DAY... with UPS... and have for the past 2 years... and these are big boxes... about the size of the box my barkers came in... and only once have i had an issue.... so i think you will be ok..
Diz - man i ffel for you... that must suck.... im just saying that not very often do things like this happen, just sucks that it happened to you (in NO WAY am i affliated with UPS)(just use them alot)... im glad to hear JAson took care of you... i figured he would

Later
Plattner
 

·
Registered
Joined
·
657 Posts
My box was beat to hell too. The only problem with anything was a small scratch on one of my pipes, nothing I can't just take care of. You could tell it had nothing to do with Jason at the Rocket Factory just UPS :mad:. I can't wait to get it all installed and ride but I am still kinda moving into my house and can't even walk in my garage let alone work on anything :'(

Jay
 

·
Registered
Joined
·
575 Posts
i bought a new gun off of cabelas, and sure enough it came UPS and the box was bent to shit. good thing all the foam inside protected it,
 

·
Registered
Joined
·
648 Posts
I just got mine yesterday,and the box looked like a fat UPS lady sat on it. And one part of the headers was peeking out of the box...prolly trying to get some air!! :thumbsup:
 

·
Registered
Joined
·
39 Posts
TimelessR1 said:
I just got mine yesterday,and the box looked like a fat UPS lady sat on it. And one part of the headers was peeking out of the box...prolly trying to get some air!! :thumbsup:
LOL, mine too. Exactly. I had a little damage and Jason took care of me as well. The map seems to be running a little lean. I havent had a chance to run it yet tho, just idle and rev for 10-15 minutes. The pipes are red (which I know is normal) but I pulled my plug and it is white on the tip. I'm going to have to pull my idle down as well. It is sitting around 1850. Im going to try to fatten it up a little.
 
G

·
Discussion Starter · #19 ·
I have to check my plug but it seemed alright to me, I took it out and it responded well. My pipes didnt glow than bad, normal to me.once again thanks goes to Jason and I'm glad to deal with him rather than UPS. :thumbsup:
 
1 - 20 of 35 Posts
Top