Raptor Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
85 Posts
Discussion Starter #1
Two days ago I was riding at the local pit, when i saw a dollar bill on the ground :D, so i parked my quad next to it (on a hill), and put on the parking break, and let off the foot break. I immediatley started rolling backwards,wonndering why.??? I turned the parking break off, and then back on. Same happened.:mad: i looked at the cable that attaches the lever to see if it got detatched, but it didn't, and it looks fine. It even tightens when i tun the lever. I was just wondering, whats the problem??
 

·
Master of the Electron
Joined
·
15,065 Posts
The parking brake needs regular adjustment (using that bolt and locknut in the center of the PB assembly by the caliper)- as the brake pads wear, the PB needs to be adjusted accordingly - it's not automatic.

I don't know many ppl that have a working PB anymore - except for my Polaris, which locks the hand brake lever directly - keeping hydraulic pressure on the brakes.
 

·
Registered
Joined
·
85 Posts
Discussion Starter #3
thanks, but when you adjust it, is it as simple as tightening a screw, or do you have to tighten/ loosen it, and test it, repeat, repeat.
 

·
Master of the Electron
Joined
·
15,065 Posts
Just tighten so it grabs when on, releases when off... not a lot of test and repeat required.
 

·
Registered
Joined
·
77 Posts
eliminate the parking brake. its junk.... it needs adjusted every 5 mins of riding for it to work... at least on the the 660
 

·
Premium Member
Joined
·
354 Posts
they never work you just have to turn the quad off and put it in first
 

·
Registered
Joined
·
538 Posts
Ive had my quad since 2007, and my parking brake still works great. Never had a problem with it. :d
 
1 - 10 of 10 Posts
Top