Raptor Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I'm 14 year old kid and I need help with my raptor. It's a 2007 raptor. For the past 2 weeks it would randomly start sputtering and back firing like it was out of gas even though it had a full tank. Once I would shut it off after it would do that it wouldn't start til like the next day. But once i got it started again it would run great for the rest of the week. Now a couple days ago it fired right up but when I tried to back out of my driveway it died and soon as I hit the throttle. And it hasn't started since. If anyone can help thanks.
 

·
Administrator
Joined
·
9,550 Posts
Welcome to the forum. Can you provide some more detail about your bike? What year, what is aftermarket items on it, such as exhaust or intake. Start by replacing that spark plug and when you start it up, do not give it any throttle until it is warmed up. That will cause the plug to foul.
 
  • Like
Reactions: Sixpack577

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
Welcome to the forum. Can you provide some more detail about your bike? What year, what is aftermarket items on it, such as exhaust or intake. Start by replacing that spark plug and when you start it up, do not give it any throttle until it is warmed up. That will cause the plug to foul.
Ok. Thanks it's a 2007. It's completely stock. I'll will try that. I just cleaned the carb and that didn't do anything so well see what happens.
 

·
Registered
2022 Yamaha Raptor 700r
Joined
·
155 Posts
Did you take out and clean each individual jet in the carb? Make sure you always spray some carb cleaner through them even if they look clean. A little bit of gunk can block up a jet and cause a problem. How does it run if you fully choke it versus if the choke is off? Also welcome to the forum!
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
So the guy before me really messed up the carb screw. Everyone was stripped out. So the kid that was helping me said spray carb cleaner in every possible hole. I got the bowl full of carb cleaner let it sit for a couple hours then drained it. I said in my previous comment that I didn't help at all buts not true. It starts fine and runs better but it still will sputter a little just casually driving it. But only on dirt roads. If I go full throttle it will barely run. Just sputters and backfires. So yeah it's a really weird problem..
 

·
Registered
2022 Yamaha Raptor 700r
Joined
·
155 Posts
Is just the fuel screw stripped or several different screws on the carb? If the carb is that messed up then I'd look for a good used one to replace it. You need a well functioning carb in order to start ruling issues out.

I had a 05 Eiger with a issue like that where sometimes it'd run ok then lose all acceleration. I ended up taking the gas tank off and completely cleaning everything out, and then putting an inline fuel filter to the carb after I completely cleaned the carb. After that I never had another issue. There was a lot of dirt and sediment in the tank that was causing the issue. Might be worth a shot checking.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Is just the fuel screw stripped or several different screws on the carb? If the carb is that messed up then I'd look for a good used one to replace it. You need a well functioning carb in order to start ruling issues out.

I had a 05 Eiger with a issue like that where sometimes it'd run ok then lose all acceleration. I ended up taking the gas tank off and completely cleaning everything out, and then putting an inline fuel filter to the carb after I completely cleaned the carb. After that I never had another issue. There was a lot of dirt and sediment in the tank that was causing the issue. Might be worth a shot checking.
Yeah every singe bolt on the carb bowl is stripped as well as the drain plug. But I was able to get the plug out and spray carb cleaner through there fuel line to fill the bowl up. I'll check that out if I need to. As if now it's running fine. The fuel cable was really loose so I think the vibration or something would move the cable in and out to stop giving it gas for a second. I taped it up and went for a long ride yesterday and it did great. I also cleaned the air vent on the gas cap. Cuz a kid that is helping me thought that maybe that was plugged to it wasn't flowing good to the carb cuz there was no air in the tank. So idk what did it but I think it's fixed.
 

·
Registered
2022 Yamaha Raptor 700r
Joined
·
155 Posts
Yeah every singe bolt on the carb bowl is stripped as well as the drain plug. But I was able to get the plug out and spray carb cleaner through there fuel line to fill the bowl up. I'll check that out if I need to. As if now it's running fine. The fuel cable was really loose so I think the vibration or something would move the cable in and out to stop giving it gas for a second. I taped it up and went for a long ride yesterday and it did great. I also cleaned the air vent on the gas cap. Cuz a kid that is helping me thought that maybe that was plugged to it wasn't flowing good to the carb cuz there was no air in the tank. So idk what did it but I think it's fixed.
Hey as long as it's fixed enjoy the ride! Glad it's up and running now. I think there's service manuals for your quad somewhere on here if you do a search. Might help with basic info about your quad if you don't have one already.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #9 ·
Hey as long as it's fixed enjoy the ride! Glad it's up and running now. I think there's service manuals for your quad somewhere on here if you do a search. Might help with basic info about your quad if you don't have one already.
Thanks for your help. I'm a little annoyed that it was that simple to fix but also super happy it was that simple. Thanks everyone.
 
1 - 9 of 9 Posts
Top