Raptor Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I just made my own slipon using a KTM 520sx silencer. It gives a great sound and good power, the only problem is during enginebrake. When I let go off the throttle and enginebrake I get loud pops and eventually loud bangs. I´ve tryed different maps and modified maps but there is no difference between them. I´ve checked for leaks on the exhaust and midpipe and it´s just fine, checked the sparkplug and it´s brown. My bike is streetlegal and it´s just a matter of time before the cops pull me over fo disturbance.

I use stock filter and a powercommander.

Anyone got any suggestions?
 

·
Registered
Joined
·
125 Posts
I RUN A PRO FLOW FILTER SETUP, DYNO POWER COMMANDER AND REMOVED MY STOCK SILENCER AND I HAD THE SAME PROBLEM. WHEN YOU LOAD THE MAPS ADD LIKE 2% AT EACH COLUMN AND YOU WONT HAVE THAT PROBLEM. THE PREPROGRAMMED MAPS ARE WAY LEAN. CHECK YOUR SPARK PLUG I BET IT IS REALLY WHITE.
 

·
Registered
Joined
·
12 Posts
Eventhough I run stock airfilter I should add 2% on each column? At the moment I use a modified version of map number 010, originally to be used with gytr filter and gytr slipon, doubt that I could be lean on that map?
 

·
Registered
Joined
·
3,586 Posts
YFZ RAPTOR 700R said:
I RUN A PRO FLOW FILTER SETUP, DYNO POWER COMMANDER AND REMOVED MY STOCK SILENCER AND I HAD THE SAME PROBLEM. WHEN YOU LOAD THE MAPS ADD LIKE 2% AT EACH COLUMN AND YOU WONT HAVE THAT PROBLEM. THE PREPROGRAMMED MAPS ARE WAY LEAN. CHECK YOUR SPARK PLUG I BET IT IS REALLY WHITE.
...........a lot of people say the maps are REALLY RICH TOO.......Also, what do you expect...these maps are made for specific applications, not back yard exhaust setups.


In answer to the question, your going to have to play with the maps and like he said add fuel or take fuel away. What does your plug look like?
 

·
Registered
Joined
·
37 Posts
KTM Danne said:
I just made my own slipon using a KTM 520sx silencer. It gives a great sound and good power, the only problem is during enginebrake. When I let go off the throttle and enginebrake I get loud pops and eventually loud bangs. I´ve tryed different maps and modified maps but there is no difference between them. I´ve checked for leaks on the exhaust and midpipe and it´s just fine, checked the sparkplug and it´s brown. My bike is streetlegal and it´s just a matter of time before the cops pull me over fo disturbance.

I use stock filter and a powercommander.

Anyone got any suggestions?
On the first column ONLY, this column is your idle, you need to richen it up from. On my Harley, I had to richen it up to 5 to keep the decel pops from happening. EFI, when the throttle is closed, no fuel goes into the combustion chamber except the map on the first column...period.
 

·
Registered
Joined
·
12 Posts
I´ve had 6 on the first column (using the 010 map) guess I have to richen it up even more and see what happens. By the way at what rpm do you guys set your idle? Really thinking of putting my stock exhaust back on.......
 

·
Registered
Joined
·
1,346 Posts
question of stupidity, iam new to the efi quads. you say change or modify the maps, iam guessing but dont you need a pc programer or is their a another way to do it??
 

·
Registered
Joined
·
125 Posts
my friends and i have 5 raptors between us and we all have air filters and modified spark arrestors...after raising the full a few percent with our power commanders we all got rid of popping. dont worry about going too rich cause chances are you are running way lean right now. your spark plug wont lie.
 

·
Registered
Joined
·
12 Posts
Swapped back to stock silencer earlier today and changed to the map with muffler and lid removed, still have popping issue. Is it possible you could send me your custom map just to see if this is the problem? Cause I use to have this mod without popping and now as I go back I get popping. Damn this is fucking science, I just wanna ride
 

·
Registered
Joined
·
37 Posts
KTM, if you richen up the first column and it didn't go away, you've got a leak somewhere. Check all your exhaust clamp points, all your intake tubes/clamps, etc... Your sucking in too much air besides the air coming from your air filter. Also, disconnect your battery for about 2-5 minutes and re-install it. This should also clear your sensors... Good luck and let us know if it worked or not. I'm pretty sure it will be one of the above...
Kam
 

·
Registered
Joined
·
125 Posts
i am not trying to insult your intelligence but are you sure you are applying the maps and tables. i cant immagine that you cant get that popping to stop. maybe try going back to the stock map and see if it works.
if you send me your email i will send my map to you. i tried to post i but i couldnt
 

·
Registered
Joined
·
12 Posts
This weekend I had the bike torn apart, set the valves, checked all the plugs, the tps and checked the exhauset for leaks. Connected it to a wideband module and now (with stock silencer) it´s fine again. No backfiring, popping etc. All thanks to my raptormentor Iroc who helped me out. :thumbsup: As the winter is closing in on us here in Sweden and our blondes crawl back to their holes, waiting for spring to return I´ve rigged a set of snow and ice tires and damn it´s gonna be fun riding the snow.

Thanks everyone for your help and support
 

·
Registered
Joined
·
7 Posts
whats up i have a 06 700 i just added a gytr full exhaust and filter system and pc3 i loaded the map from dynojet but i feel like i loose alittle at top end would i be ok to add more fuel across the rpm range like 2% or so or does anyone have a cutom map that i could use ill be going to pismo for thanks giving so please let me know
 

·
Registered
Joined
·
19 Posts
In my opinoin, take it to some one to dyno tune ur bike. And when you get ur bike back u will be a believer in dyno tuning!!!!!!!!!!!
You can't make chicken soup, with chicken poop!!!!!!!!!
 

·
Registered
Joined
·
383 Posts
4year old thread. I like that you used the search function. but that's a little excessive lol
 
1 - 18 of 18 Posts
Top