Raptor Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter · #1 ·
Hi guys im having trouble starting the the raptor.I do tend to leave my bike sitting outside without no cover or any protection,so it does expose my bike to see some rain and hot sun shine.The thing is i had a similar problem before when i couldnt get it to run.And the problem was due to a dirty carby and filter.
But now when i turn the key & press the start button in neutral and light for neutral comes on .I cant hear the relay buzzing or clicking.I had sparks come out of the terminal where the battery is but now sieze to do so.My battery is fairly new and i had to grind away and smooth a melted battery terminals due to trying to start my bike alot of times in a short duartion on one occasion.

Now i think the problem may be eithier that the start engine button is the problem because it my be exposed to water?

Or the relay is broken ,but the fuse is still good in them.

Or could it be the stator.

How do i bypass the engine start or relay to start the engine?

please help?
 

·
Master of the Electron
Joined
·
15,550 Posts
The neutral light should be on when the key switch is on and the bike is in neutral. THe TEMPERATURE light comes on while pressing the start button.

If the temp light comes on when pressing the button, the button is working.

Cover your quad - rain is truly its enemy.
 

·
Registered
Joined
·
13 Posts
Discussion Starter · #4 ·
Thanks for the advice! And just order a atv cover off ebay the other day.Solid invsetment i reckon.MY poor atv copped it for to long!Hopefully i wont need to do a frame respray
 
1 - 4 of 4 Posts
Top