Raptor Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
im wondering what psi i should have on my 01 660 its stock and i have not disabled the decompressor and i only got a reading of about 60 psi. does this sounds right?
 

·
I am unique
Joined
·
22,621 Posts
im wondering what psi i should have on my 01 660 its stock and i have not disabled the decompressor and i only got a reading of about 60 psi. does this sounds right?
With the decomp working, you can get any reading, just depends on how good it works, without the decomp, you should get well over 125psi depending on the piston...........
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
it runs great starts up soon as you touch the button but ive read so many conflicting things about people saying you should be getting a 120psi reading even with the decomp and i was just wondering if it sounds like its bad?
 

·
Premium Member
Joined
·
956 Posts
I don't know, but if it runs good don't mess with it.
 

·
Master of the Electron
Joined
·
15,627 Posts
it runs great starts up soon as you touch the button but ive read so many conflicting things about people saying you should be getting a 120psi reading even with the decomp and i was just wondering if it sounds like its bad?
"People" are wrong.
 

·
Super Moderator
Joined
·
17,061 Posts
Manual states 132psi with the decomp functioning. Around 180 without it.
 

·
Premium Member
Joined
·
956 Posts
I wish my sled had that much compression, but then I do keep it at 10,200 feet, lol
 

·
Registered
Joined
·
435 Posts
also it would not hurt to borrow a buddys tester i found mine had a leak somewhere giving me false readings...thought i would throw that out there.
 

·
I am unique
Joined
·
22,621 Posts
You need more then 90 psi to promote combustion...............
 

·
Master of the Electron
Joined
·
15,627 Posts
60 certainly sounds like a leaky test since the engine starts and runs well. But I've seen more measurements in the 100's with the decomp than the 132 the manual states.
 

·
I am unique
Joined
·
22,621 Posts
On two strokes I have found that once you are below 93 psi compression, it will not start..............
I would think that four strokes shoud be similar.............
 

·
Registered
Joined
·
6,002 Posts
On two strokes I have found that once you are below 93 psi compression, it will not start..............
I would think that four strokes shoud be similar.............
My banshee was at about 90psi and I would have to kick it over for about 10min before it would fire lol. It would fire fine after it was warm so after 10 min of kicking it would make enough heat and fire lol. I would be so tired by the time it was running I couldn't ride.
 

·
Premium Member
Joined
·
4,191 Posts
Dog, that just means you need to do more cardio haha. Just playin man, 10 minutes is a bit much, I would say 8 is about all it should take to kick it over lol. You would have been good to ride at that point...
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #16 ·
well it starts with the touch of the button, after its been running it takes a turn or two but never spins for more than a second so i guess im good.
 

·
Registered
Joined
·
6,002 Posts
Lets just say I would not be able to kick it over that long anymore. That was back in my landscaping days and I was in alot better shape then I am now... I would make it about 2 min of kicking now and be done. Now this electric start has me lazy.:cool:
 

·
Premium Member
Joined
·
4,191 Posts
Haha, I'm just busting your balls man. I hear ya, these electric starts are making us all lazy! I think your 2 min has me beat anyway, lol. 30 seconds and I'd be using one of my timeouts.
 
1 - 18 of 18 Posts
Top