Raptor Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6,514 Posts
Discussion Starter #1
My buddy has a yfz and it cuts out sometimes or his lights wont work and he has to shake it to get it to work, , someone told him it's the ignition regulator? or eletric regulator?.
and i'm trynig to find the part for him,but i dont' even know what the part is called, i know alot of you had yfz's, any idea what the piece actually is? and where i can find one?
the stator? is that it?
 

·
Premium Member
Joined
·
601 Posts
I heard that some of the earlier yfz's have stator problems. They would not run as fast with the lights on. Not 100% sure but almost certain.
 

·
Registered
Joined
·
6,514 Posts
Discussion Starter #3
ok, thanks, that's a big start, the dumb thing is, he had someone at the dealer look at it and they told him what to get, and now he forgot, and i'm ok dumbass call the dude back and ask him, i don't really like wild goose chases....man, the things i have to go through for other people just to make sure i have a riding buddy!!,
 

·
Registered
Joined
·
6,514 Posts
Discussion Starter #4
it's the voltage regulator, does that sound right?.
also just for fun here is his quad, looks good for stock, i wish my rappy was all black...
 

·
Registered
Joined
·
3,586 Posts
TEXAS700 said:
I heard that some of the earlier yfz's have stator problems. They would not run as fast with the lights on. Not 100% sure but almost certain.

I think your a little off, but close. There was indeed a problem with the earlier models in 04....and I mean early. The quad ran the same....there was no performance issue....you had to run with the lights on to make the charging system charge the damn battery. If you didnt, the battery would never recharge itself and would die rather soon.
 
1 - 5 of 5 Posts
Top