Raptor Forum banner

1 - 5 of 5 Posts

Registered
Joined
3 Posts
Discussion Starter #1
Ok 05 raptor harness is crap and I have no fire I have replaced the whole ingniton system including CDI box this includes new stater, pulse coil, ignition coil, rectifier, even replaced starter and starter relay. I have studied these forums thru and thru and have gained knowledge of the wiring harness wires and colors I need and ones I dont. Ok my main question is before I go and fry my new CDI is to make sure this is the correct harness for this 05 what is making me question this is the three plugs on my CDI one of the three plugs only has one wire! A green and yellow I believe. Is this correct and is this just my parking brake light?
 

Master of the Electron
Joined
14,887 Posts
You have an 01 harness. Look at "The Differences Between 01 and 02+ CDI Wiring Explained" sticky in 660 Maintenance (see below).

DO NOT try to power up your 05 CDI with this harness (unless you make the changes described in the sticky), you can permanently damage the CDI.

 

Registered
Joined
3 Posts
Discussion Starter #3
Ok well too late I already have fried two CDI boxes it seems!! With this said can I ask this. Will an 01 CDI box work with the O5 engine if so can't I just buy an 01 CDI box and plug it up and go?
 

Master of the Electron
Joined
14,887 Posts
Yes you can use an 01 CDI on your 05 engine AFTER you verify that the wires in the 3 CDI connectors in your harness match those as described in the factory manual... don't want to blow another!

The one on the right is NOT a picture of a 660 CDI, period! The 01 looks virtually identical to the 02-05 - someone else will have to tell you if there are any discriminating features between them.

Have you downloaded the manual yet?
 
1 - 5 of 5 Posts
Top