Raptor Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello I need help ! My 2002 Yamaha Raptor 660 will not turn over when the valve cover is on and when I do try the nut comes loose, but when the valve cover is off I can turn it over like butter , and yes the plugs out!
 

·
Master of the Electron
Joined
·
15,454 Posts
Welcome to the forum!

Check cam timing.. bet it's slipped a few teeth - also bet your timing chain is stretched out.

There are other possibilities but this is most likely.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks for the reply! You were spot on but one more thing the person who I bought it from mixed matched the valve cover and Head! Just got one on marketplace and slapped them on and she’s as good as new also top end!!

Welcome to the forum!

Check cam timing.. bet it's slipped a few teeth - also bet your timing chain is stretched out.

There are other possibilities but this is most likely.
 

·
Master of the Electron
Joined
·
15,454 Posts
You're lucky - they are line bored as a pair from the factory... to find another cover that works is unusual - it will fail early, most likely. as the cam journals wear out.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
You're lucky - they are line bored as a pair from the factory... to find another cover that works is unusual - it will fail early, most likely. as the cam journals wear out.
Hello and thanks for the reply I bought a set as in the head and the cover matching off of market place! Thanks again.
 

·
Master of the Electron
Joined
·
15,454 Posts
Great - good luck and ride!
 
  • Like
Reactions: Aldin63
1 - 6 of 6 Posts
Top