Raptor Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
Hi guys, new to this forum and desperately need some advice. I have a 2018 700 with the dynojet power commander, FMF exhaust, powerbomb header, and a K&N filter. When plugging the power commander into the laptop, I saw the Raptor was idling at around 2k RPM. Not sure if that’s normal or what map I should use for the set up I have. I saw the air box said it should idle at 1600 RPM.
1580045296574.jpeg

138205
 

·
Super Moderator
Joined
·
7,794 Posts
There is actually a process for adjusting the idling down if I recall correctly, not just turning that screw. Send me a PM with a valid email Archie and I can send over a service manual you can look over.
 

·
Registered
Joined
·
280 Posts
Use the screw with the spring, it is for adjusting the idle. It adds or removes air without moving the butterfly valve on the TB. If you have to back it out so much that the spring has no tension, then you need no adjust the butterfly valve set screw. Curveo has a good YouTube tutorial on how to assemble and adjust TB's.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
Yea, trying to figure out the fuel map I need to run... unfortunately I can't find one for the mods I have. Any idea on where to find maps that are similar for the set up I have?
 

·
Registered
Joined
·
301 Posts
Yea, trying to figure out the fuel map I need to run... unfortunately I can't find one for the mods I have. Any idea on where to find maps that are similar for the set up I have?
Yeah like 418 said just got to their site and look through all the maps.
I called the rep and talked to him about all the maps cause they didn’t have one that was for my mods, but he said they are all so damn close it wouldn’t matter much. He advised to choose my exhaust type and then try a few of the maps for it. I found one on the first try that worked SO much better than whatever came on my quad from the last guy.
 

·
Super Moderator
Joined
·
7,794 Posts
If you dig through some of the archived threads in here, there are a couple of threads that guys have provided maps from their builds. If I find some time I can search and make it a sticky if it isn’t already. I used a couple off that thread until I made it to a Dyno.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #12 (Edited)
I tried adjusting the idle with the screw and running different maps from this forum. I pulled some from the power commander site too, but for some reason I’m still getting flame out the exhaust when I give it a little throttle in neutral. It used to be the headers would glow red at idle but it’s gotten to the point where the exhaust gets so hot it melts the plastic guard I put on. Worried it’s getting way too hot and I’ll mess up the engine.
Again, definitely appreciate all the help and responses! I’m a newbie to this ATV stuff and I just feel like I’m already way in over my head lol. I just got this a few months ago and I only got it going on Lost Trails once in PA. Trying to get it ready for riding soon!
 

·
Registered
Joined
·
280 Posts
Flame out the exhaust pipe is from unburned fuel that ignites in the exhaust. Additional air introduced through the AIS or an exhaust leak can cause popping, it helps ignite unburned fuel in the exhaust. What % fuel do you have in the 0 column with the current map? As a general rule each 10% change in the PCV changes the AF ratio 1 point. Did you purchase the PC from a vendor on this site, if so they will help you out with maps and advice.
 

·
Registered
Joined
·
86 Posts
I tried adjusting the idle with the screw and running different maps from this forum. I pulled some from the power commander site too, but for some reason I’m still getting flame out the exhaust when I give it a little throttle in neutral. It used to be the headers would glow red at idle but it’s gotten to the point where the exhaust gets so hot it melts the plastic guard I put on. Worried it’s getting way too hot and I’ll mess up the engine.
Again, definitely appreciate all the help and responses! I’m a newbie to this ATV stuff and I just feel like I’m already way in over my head lol. I just got this a few months ago and I only got it going on Lost Trails once in PA. Trying to get it ready for riding soon!
Dude, send me your email, I can send you my current map, you can give it a try and tell me how it works for you.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #15
@418Stroker I need to pull the map. I have the Power Commander FC, I’ll check when I get home. I bought it used with the mods/ maps and it seemed to run fine in the beginning. A little lean but I wasn’t getting flames out the exhaust.

@Yamil Xiscatti I’ll PM you my email

Again, thanks guys! I spoke to Dynojet and they said maybe the maps weren’t saving correctly to the Power Commander. Going to give them another call once I try running different maps. Going to try Yamil’s map and see how it runs with that.
 
1 - 15 of 15 Posts
Top