Raptor Forum banner
1 - 20 of 28 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
I have had this 2013 raptor 90 for a year. It didnt run when I got it.... I pulled carb cleaned it, opened main jet to 37. The bike has run good all summer and havent had any issues with it. A month ago my daughter and I where ridding and it seemed not to run well unlees the choke was half way on. When we got home the idle was high and we shut it off. I thought the carb would need cleaned so I didnt mess with it. Last week I went to start it and it wouldnt even fire. I cleaned carb and it fired up, but wouldnt come off idle. Thought main jet was still clogged, so I cleaned it again. I have had this carb apart 5 times and even boiled it lemon juice and water to make sure everything was clean and clear. It will fire and almost idle but will not take any throttle or run off choke. Plug spark looks good air filter clean....Any ideas?

I know this sounds like main jet but I can get a wire and air through it.
 

·
I may be getting older, but I refuse to grow up!
Joined
·
11,733 Posts
I have a few questions.
Fresh fuel?
Good fuel flow from tank?
Float works properly?
Clean air filter?
Fresh spark plug?
Valves adjusted?

WELCOME TO THE FORUM.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #3 ·
Fresh fuel? yes
Good fuel flow from tank? yes
Float works properly? yes
Clean air filter? yes
Fresh spark plug?new
Valves adjusted? didn't check

Bike might only have 15 hours on it, I didnt think that would need done yet, but i can look at that.
 

·
I may be getting older, but I refuse to grow up!
Joined
·
11,733 Posts
You've got the bases covered. Did you run a copper wire thru ALL carb passages? I once had a jet that looked clean to see thru, but was still dirty. Valves are a shot in the dark, but....a locknut may have come loose.
 

·
Registered
Joined
·
318 Posts
Sounds like an air leak to me
I would check the pipe between the motor and carby, it it's split it will suck air and cause the issues you describe
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #6 · (Edited)
You've got the bases covered. Did you run a copper wire thru ALL carb passages? I once had a jet that looked clean to see thru, but was still dirty. Valves are a shot in the dark, but....a locknut may have come loose.
Checked jets with wire and they are all good. I might try to check valves today...just in case.

Sounds like an air leak to me
I would check the pipe between the motor and carby, it it's split it will suck air and cause the issues you describe
I will check this also
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #13 ·
Ok, I did a compression test and with throttle wide open and I am getting between 180 and 185 psi.

I also bought an ultra sonic cleaner and re cleaned the carb....Must say it really worked well.

Bike still will barely run, is really hard to start, and stalls when you give it any gas.

This thing is driving me nuts......:mad:

Thanks for the help

Brian
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #15 ·
accelerator pump is working good...checked it when I cleaned the carb again.
Borrowed a CDI and that is not the problem ether. This thing is driving me nuts.:mad:

I am starting to think about swapping this carb out with another.

Any suggestions?

Thanks for all the help...

Brian
 

·
I may be getting older, but I refuse to grow up!
Joined
·
11,733 Posts
Have you tried 'starter fluid'? It still sounds like a air/fuel problem.
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #18 ·
I will grab some starter fluid and see if it runs on that.

I had the mixture screw out when cleaning carb. I set it 1.5 turns out to start and moved it all over the place with no change.
 

·
Registered
Joined
·
34 Posts
Shit......I am having the same issue. I have taken the carb apart several times, cleaned it each time, and still wondering what the crap is going on. Is there a safety device that could be keeping it from revving up like the rear brake on a banshee? Okay if I get a different carb can I still run the thumb throttle?
 

·
Registered
Joined
·
19 Posts
Discussion Starter · #20 ·
I swapped carbs out and it runs great. Stock carb is junk IMHO.
I have never cleaned a carb sooo many times and different ways and not got results.
 
1 - 20 of 28 Posts
Top