Raptor Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Questions for you guys, I have a 2015 raptor 700 with full monster shorty exhaust, pro design air intake and a PC V with a Mr Cuervo racing map.. the last two rides I went on I’ve been having issues with the bike cutting out.. the first time I noticed anything I was in 3rd gear high rpm’s and started stuttering. No other issues besides high rpm’s 3rd gear.. next time I went riding I started having issues with the bike stuttering in all my gears, the warmer it got the worse it became.. it eventually started shutting off on me even when I was in the throttle.. no engine lights or anything like that lit up.. I was able to restart the bike every time it died and rode it back to the truck.. went to unload it when I got home and it had a hard time staying running.. haven’t had a chance to ride again since then but started it up the other day and it started fine and idled fine.. any suggestions about what might be going on?
 

·
Registered
2019 raptor 700 R SE. Monster single shorty full exhaust, pcv 5 with timing.
Joined
·
875 Posts
Did you charge the battery after it went weird on you? Im having literally the exact problem you are having. I’m replacing my stator cause the battery is not getting charged so basically it kills your battery after a couple hours of riding.
anyway I’d check your spark plug see if it’s fouled, then check your rectifier/ regulator, and stator. Make sure you have a good battery too.
Easiest way to see if it’s charging is start your quad and you should have at least 14 volts while Idling.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
I have taken my quad to a shop to have them check things out. I can’t seem to get it figured out.. From a lot of the forums I’ve read this seems to be an issue that no one has a true answer for.. I’ve seen everything from TPS sensor, ignition coil, water temp sensor, faulty fuel programmer, stator, screw position of thumb throttle.. hoping I can get this fixed to help others who are dealing with the same issues.. so far at the shop have adjusted my fuel programmer to the correct tune didn’t fix the issue, they have ordered a dynatec ignition coil cause I was reading high resistance across factory coil.. I’m not sure this is gonna fix the issue either from what I’ve been reading but will keep you all posted as they continue work on it..
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #7 ·
Did you charge the battery after it went weird on you? Im having literally the exact problem you are having. I’m replacing my stator cause the battery is not getting charged so basically it kills your battery after a couple hours of riding.
anyway I’d check your spark plug see if it’s fouled, then check your rectifier/ regulator, and stator. Make sure you have a good battery too.
Easiest way to see if it’s charging is start your quad and you should have at least 14 volts while Idling.
I’ve been reading a lot of your post def sounds like we are in the same boat, I’ve taken it to a shop cause I’m at a loss now of what it could be.. I’ll keep you posted if they find out whats going on.. I’ve got a brand new battery on it and is testing to correct voltage.. it’s fires right up every time and if I don’t get into high RPMs it will ride just fine.. it’s when I punch the throttle that it starts cutting out..
 

·
Registered
2019 raptor 700 R SE. Monster single shorty full exhaust, pcv 5 with timing.
Joined
·
875 Posts
literally have your exact symptoms,
I also have mine in a shop lol just waiting for the mechanic to have some time to look at it. I gave up I have no clue.
 

·
Registered
2019 raptor 700 R SE. Monster single shorty full exhaust, pcv 5 with timing.
Joined
·
875 Posts
Well it for sure jus ain’t charging, tried a different oem stator from my brothers bike that worked perfectly fine for him, on mine and no change, as posted before stator is new and is right to specs.
gonna try hooking it to my dads quad battery to see if maybe the battery just isn’t holding a charge very well, but doubt that will help.
So let’s narrow this down: stator-wiring-rectifier-wiring-battery.
So if it’s not stator, battery, or rectifier, must have a short some where, yeah or am I missing something?
I can see the voltage fluctuate when it cuts out. Down as low as 13 volts but with the lights on it’s like 12.5 and then just kills it. It was idling at 14 but just revs like shit and now won’t even start. Not sure how or if my tuner would affect this, since the symptoms are so random.
 

·
Registered
2019 raptor 700 R SE. Monster single shorty full exhaust, pcv 5 with timing.
Joined
·
875 Posts
Not sure if this means anything but every time I remove the stator plug, it runs good as long as it’s getting power jumped from another quad. Otherwise it runs super shitty with the stator plugged in.
 

·
Registered
2019 raptor 700 R SE. Monster single shorty full exhaust, pcv 5 with timing.
Joined
·
875 Posts
Well I’ll look into the cdi cause I haven’t checked that, not sure where it is even.
I’ve had both an aftermarket as well as his oem rectifier and his runs perfect at a 14.00 volts so I know his is working good.
 

·
Registered
2019 raptor 700 R SE. Monster single shorty full exhaust, pcv 5 with timing.
Joined
·
875 Posts
I’m gonna maybe switch ecu, which I think you mean, but the problem is originating from the stator, rectifier area. Cause it’ll run good as long as I disconnect it at the rectifier or stator. Not sure what all that means though.
 

·
Registered
2019 raptor 700 R SE. Monster single shorty full exhaust, pcv 5 with timing.
Joined
·
875 Posts
So everything from stator to rectifier looks exactly the same on both quads, reading wise. And I wasn’t sure whether to swap ecu or not since his looked different than mine, so I’m wondering did they change them and if so how do I test mine? Most importantly does your return power from the rectifier go through the ecu before going to the battery, cause with how weird the symptoms are I’m kinda thuinking ecu
 

·
Registered
2019 raptor 700 R SE. Monster single shorty full exhaust, pcv 5 with timing.
Joined
·
875 Posts
Well I’m just gonna buy a new ecu because everything checks out so idk what tf, and the symptoms vary so much, not to mention it’s so new and has such low hours all the wiring has got to be ok. So hopefully that’s it.
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top