Raptor Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter #1
I did some searching and could not find the answer so I figured its time to ask the question and see if I can get help from fellow raptor riders. I have an 07 Raptor and fuel pump quit. Didn't hear anything so i ordered a new pump kit. Got the pump out and replaced the necessary parts and when i was putting it back together I noticed a black wire dangling from the other plug in on the underside of the pump lid. I pulled the plug and noticed that there should be actually 2 wires coming from there. Upon further investigation and scavenging the internet for pictures to see where this dangling wire should lead I found that there are 2 said wires (black and white) coming from that plug that go to a plastic case that mounts to the side of the pump with an metal rod. Dug my hand around in the tank found that piece. Did some soldering and manipulating of connections thought I had everything back how it should go and I am still not getting the pump to function. Does anyone know if that particular piece can be purchased and what is it called I will go take a picture and upload it if necessary. Thanks in advance for your help all.
 

·
Registered
Joined
·
123 Posts
Can it be purchased by itself? Would that keep the fuel pump from running?
I wouldnt think so.
That I'm sure is just the sending unit for low fuel light.
Maybe fuse blew.
Did you check them
Also you can run wires from the battery and manually se if the pump works.
 

·
Registered
Joined
·
107 Posts
Discussion Starter #8
I wouldnt think so.
That I'm sure is just the sending unit for low fuel light.
Maybe fuse blew.
Did you check them
Also you can run wires from the battery and manually se if the pump works.
I did check the fuses. Those are good. Relays are clicking. I will manually try the pump (both new and old) see I I can get them to work.
 

·
Registered
Joined
·
107 Posts
Discussion Starter #11
Did you check for 12v at the pump when you turn the key on.
I tried a number of different ways to check the pink and black wires. I can’t seem to get a reading of voltage that I can tell. What / where are the points before that. All Fuses checked and seem to be in good working order. I hear at least one relay click when key switch get turned on. How many relays are there? Locations?
 

·
I may be getting older, but I refuse to grow up!
Joined
·
11,045 Posts
Did you test the pump relay per the manual?

brown/green and red/blue

red/black and blue/red
 

·
Registered
Joined
·
123 Posts
Atthebottom of the pump relay Brown and green wire should have 12v to ground.
Red and black will have 12v to ground.(black meter lead on the frame somewhere)
If relay is working you should read 12v to ground on the red and blue wire.which goes to the pump
When the key is turned on.
 
1 - 13 of 13 Posts
Top