Raptor Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
105 Posts
Discussion Starter · #1 ·
i have a 660 raptor and ever since i rejetted for full exhaust its starts very hard and sometimes i wont start at all till the battery goes dead. i have jetted to the exhaust mfg specs except for dyno jet needles and the piolets are clean i just had the carbs apart a week ago to check it out. i have to choke it on and off and give it alot of throttle for it to fire. whats up? starts good after it warms up
 

·
Registered
Joined
·
343 Posts
what does your spark plug tell you? lid or no lid? may be too lean on the pilot. what size pilots? on and on...........
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #3 ·
no lid, stock piolets, k&n filter, could it be valves like someone elese said, the motor isnt really noisy like it needs it. just starts like a whore
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #5 ·
i am at a complete loss. i have done everything i can think of. cleaned everything. and adjusted ererything to where it should be. valves are good. choke plunger is engaging. need help any ideas? dealer said bowls are different and they matter what way u put them on has n e heard this. i tried both no differance. still will not start without full throttle held.
 

·
Registered
Joined
·
1,547 Posts
if it starts fine after its warm then its deffenately not electrical. if you valves are within spec then id say its the pilot jet not letting enough fuel in. just my .02
 

·
Registered
Joined
·
105 Posts
Discussion Starter · #8 ·
problem solved!!!!!!!!! i had a 4 wheeler guy look at my valves and he said they were good and they werent sloppy sounding do i didnt need to do n e thing. but come to find out they were too tight and closing too soon . adjusted them and she runs perfect. by the way exhaust valves suck to adjust
 
1 - 8 of 8 Posts
Top