Raptor Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
344 Posts
Discussion Starter · #1 ·
I am new to this forum.

I have a 06 700r and wifey has a 07 350.

I apologize if this is a repeat question but I couldn’t find the answer. (I know, fricken newbie) :chair:

The 350 rapy has a problem with the rear brakes. Every time we take it out the rear brakes go out. I have been to the dealer 3 times and the say that I have air in the brake lines. They say they have pressure checked the brake system each time and when I get it back it works just fine. Not sure what the problem is. :help:

Also, this is a new one, the parking brake does not fully engage. The handle feels really loose.

It barely has about 10 hours on her.

I am wondering if it has to do with how I transport it.

I stand it up on its rear so that mine can fit in the bed of the truck.

Has anyone had this problem? Any help would be appreciated. :3question:
 

·
Registered
Joined
·
112 Posts
i know my 700 has to be bled evey so often. And on my buddies 350 for the parking brake there is a bolt on the left side of the brake (kneeling behind it). loosen the nut and tighten the bolt alittle and it should tighten the parking brake. Just don't get it to tight or the pads will wear down really fast. I am about 98% sure that is how adjusted his. If i am wrong someone please feel free to correct me.
 

·
Registered
Joined
·
344 Posts
Discussion Starter · #3 ·
Thanks for your suggestion Jeffrocknr. :thumbsup:

I will take a look at the adjustment for the brakes and let you know how it goes.

The dealer said if it comes back in they would warranty the entire brake system. The bike is still pretty new. I wonder if this is a problem with the 350 specifically? :3question:
 

·
Registered
Joined
·
344 Posts
Discussion Starter · #5 ·
natzimus said:
do u wheelie the bike ?
when i just started wheeling that shit happened to me..
and it took a while to bleed out
No. This is wifeys bike. I have stood it on end in the back of my truck though.
 

·
Registered
Joined
·
22 Posts
eddienali said:
I am new to this forum.

I have a 06 700r and wifey has a 07 350.

I apologize if this is a repeat question but I couldn’t find the answer. (I know, fricken newbie) :chair:

The 350 rapy has a problem with the rear brakes. Every time we take it out the rear brakes go out. I have been to the dealer 3 times and the say that I have air in the brake lines. They say they have pressure checked the brake system each time and when I get it back it works just fine. Not sure what the problem is. :help:

Also, this is a new one, the parking brake does not fully engage. The handle feels really loose.

It barely has about 10 hours on her.

I am wondering if it has to do with how I transport it.

I stand it up on its rear so that mine can fit in the bed of the truck.

Has anyone had this problem? Any help would be appreciated. :3question:
You have air somewhere in your brake line. Simple solution. Don't stand it up to transport it and I bet it won't happen anymore. The sad thing is, every time your brakes go out, those rear brakes take forever to bleed.

Simple advice on the parking brake. Remove the whole assembly and put a block off plate on your caliper. That parking brake set up is the worst thing I've ever seen. As soon as your pads wear any, it is useless. I took mine off after six months of putzing with it.

Just my opinion.
 
1 - 6 of 6 Posts
Top