Raptor Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey just a quick question my bike has been acting up the last couple of days. It hasnt wanted to start unless connected to a battery charger and then charges fine and starts no problem. When initially trying to start it, it almost sounds like a bbq igniter or live wires sparking together(i dont see any spark though). I opend the air filter aswell and it smells faintly like gas but it seems there is a red oily substance in it, not very much but enough to notice. I'm thinking this might be tranny fluid but im not sure how it got there. I tried doing a search to find the answer but am not very good at navigating the site. I did however read something about the ECU? any help would be greatly appreciated.
 

·
I am unique
Joined
·
22,621 Posts
Hey just a quick question my bike has been acting up the last couple of days. It hasnt wanted to start unless connected to a battery charger and then charges fine and starts no problem. When initially trying to start it, it almost sounds like a bbq igniter or live wires sparking together(i dont see any spark though). I opend the air filter aswell and it smells faintly like gas but it seems there is a red oily substance in it, not very much but enough to notice. I'm thinking this might be tranny fluid but im not sure how it got there. I tried doing a search to find the answer but am not very good at navigating the site. I did however read something about the ECU? any help would be greatly appreciated.
Is you air filter a K&N, if so, it is probably the oil used to soak the filter so it can do its job and collect dirt and dust.......................
 
1 - 2 of 2 Posts
Top