Raptor Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
215 Posts
Discussion Starter · #1 ·
I am having clearance problems with my chain and something (cant tell what yet) that its rubbing on...I installed it a few days ago and put everything back and seemed to fit fine even reused the stock location of the case saver, but I took it out for a spin yesterday and notice that when the lifts upward like going over a bump or just before wheelie-ing it rubbs on something and I can hear it buzzz on something... I looked closer at the fitment and maybe I did not notice this before but it looks like the chain is now resting on a bushing that covers the screw for the stock heel guard...not sure if it did before or not...Could those who have this mod installed correctly chime in and or post a side pic of there sprocket for reference...I am worried that because my bike is an 07 that I may have to do something extra to make this work like with other things that changed from 06 to 07...thanks
 

·
Registered
Joined
·
58 Posts
i have a renthal 15t on an 07
you have to adj the case saver part forward
take the cover over the sprocket back off
use the slot portion to tip saver forward for more clearence...
-dan
 

·
Registered
Joined
·
575 Posts
my 06 has the same problem with my 15t i gave up on it and am taking it in on thurs to get fixed...
 

·
Registered
Joined
·
32 Posts
I have the Renthal 15 T, no problem and using the stock case saver...
 

·
Registered
Joined
·
215 Posts
Discussion Starter · #5 ·
Fea said:
I have the Renthal 15 T, no problem and using the stock case saver...
is your bike an 06 or an 07?
 

·
Registered
Joined
·
32 Posts
it´s an 06...
 

·
Registered
Joined
·
596 Posts
i have a 06...gonna put on this weekend. if i have any probs i know where im gonna
 

·
Registered
Joined
·
58 Posts
Chet said:
my 06 has the same problem with my 15t i gave up on it and am taking it in on thurs to get fixed...
get what fixed????
ill post up i pic for you guys to try and help
i cant for the life of me figure out how people are screwing this up :3question:

then again maybe cause im more mech inclined???(Master GM mech)
stay tuned for pics im going out to take then right now...
 

·
Registered
Joined
·
58 Posts
if you notice behind the plastic cover you can see the factory used hole for the casesaver
on a 15 t this is not used you tip it forward and put the bolt thru the slot in the case saver instead effectively tilting the casesaver forward to clearence the larger 15t gear
i hope this can be referenced and end any further confusion on this simple yet ofter botched upgrade
-dan
 

Attachments

·
Registered
Joined
·
575 Posts
were not having trouble with that atleast i wasnt i got that..see the roller you can barely see it in the pic my chain is putting so much pressure on that it makes a weird sound when i ride it and knocks the chain around....
 

·
Registered
Joined
·
215 Posts
Discussion Starter · #12 ·
in my case the chain is not hitting the case saver...something further toward the axel on the bottom end...when the bike would rebound upward (swing arm moving away from seat) I could hear it buzzz on something. I looked at it again last night and its not the cs....I also noticed just pulling the quad around in N it is pushing back like a brake is on but its not...so last night I tried loosening the chain a bit and sure enough that is what was causing mine to rub...it was too tight...now its as it was before...and I even re used the stock hole on the cs. I will post pics when I get home...Thanks for all your input
 

·
Registered
Joined
·
215 Posts
Discussion Starter · #14 ·
Bike is getting serviced now but it was rubbing on the plastic chain guard. The chain was way to tight but now its perfect...as a side note I just ordered some ITP bead locks pretty stoked...when I get them on my desert tires I will post pics of the madness... :grin_nod:
 

·
Registered
Joined
·
596 Posts
is that dirt or rust? Wow i thought mine looked bad
 

·
Registered
Joined
·
575 Posts
took mine in to my shop and the local mechanic messed around with it for a bit and finally got it to work, now i can say its a good mod to do :)
 

·
Registered
Joined
·
1,678 Posts
Chet said:
took mine in to my shop and the local mechanic messed around with it for a bit and finally got it to work, now i can say its a good mod to do :)
Did they tell you what was wrong with it?
 

·
Registered
Joined
·
575 Posts
havent talked to him i get off work later than their open so i just have them put it around back and hide the key :). ill call monday though.
 
1 - 20 of 23 Posts
Top