Raptor Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
So while riding on 2 different occasions ill be going average speed and my reverse light will randomly come on and the bike will actually try to go in reverse but still ride forward. Its very weird. It has only happened twice and everything is hooked up tight!! Has anyone had this issue or have i just been having shitty luck... Hahaha
 

·
Registered
Joined
·
4,836 Posts
are you sure it isnt just the light coming on due to a bad conection on the reverse switch / sensor. I would think the only way it would be able to go in to reverse while riding would be when your in 1st gear, unless you have some nasty mechanical damage done inside the transmission.
 

·
From The Stix 2 Da Brix
Joined
·
11,616 Posts
are you sure it isnt just the light coming on due to a bad conection on the reverse switch / sensor. I would think the only way it would be able to go in to reverse while riding would be when your in 1st gear, unless you have some nasty mechanical damage done inside the transmission.
+1 it shouldn't try going into reverse. I've seen and heard about fake/false lights. It's usually a lose connection some where.
 

·
I am unique
Joined
·
22,621 Posts
So while riding on 2 different occasions ill be going average speed and my reverse light will randomly come on and the bike will actually try to go in reverse but still ride forward. Its very weird. It has only happened twice and everything is hooked up tight!! Has anyone had this issue or have i just been having shitty luck... Hahaha
What you are experiencing when the reverse light coming on is the reverse rev limitier engaging due to a bad connection at the reverse switch, when the connection is lost, the reverse light comes on and the reverse rev limiter engages............

Clean the connection or simply ground the wire, this will keep the reverse light from working but also give you full power in reverse..............
 

·
Registered
Joined
·
4,836 Posts
also take a pair of pliars and slightly pinch the conector. That way it fits tight on the reverse switch again.
 

·
Master of the Electron
Joined
·
15,629 Posts
You are not feeling it go into reverse, you are feeling the engine effectively shut down, briefly, when the reverse switch wire loses contact with the switch... either clean and tighten the connector on the switch (green/white stripe wire with right angle push on plug down in front of the output sprocket) or ground the wire permanantly - the problem will go away.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #7 ·
Okay sweet fellas...yeah "limited" im defiently feeling something the fucker dont want to go haha but ill strip the reverse wires and clean and reconnect.. thanks guys... i feel loved from all the responses..:)
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #8 ·
Makes sence cuz my reverse dont really want to work... When its engaged, i have to rock my bike back and forth to actually start moving... It makes me look like a rookie cuz it stalls soo much!!!!!
 
1 - 8 of 8 Posts
Top