Raptor Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
50 Posts
Discussion Starter · #1 ·
O.K Guys, Can anyone tell me why my right carb is leaking gas from the tube connected to the bottom of the bowl. Is the float needle sticking? The left is not leaking. I am going to take the carb out and check it but before I do I would like to find out if there is something else I need to check on.

Also, my petcock valve on my tank still runs gas when the knob is in the off position. A new one is in order or what? A gasket of some sort???

Any help would be great. I will be into this Friday morning...
 

·
Registered
Joined
·
45 Posts
i've had the same problem, take the carbs off and inspect it to make sure nothing is in the needle valve. i had a spec of dirt in mine and it kept it from sealing. clean the rubber tip of the valve with a tissue, just be careful not to damage it. also wile your in there clean the drainage screws just to make sure they arent the problem. as far as the petcock just replace it, after buying the gaskets and what not, for another ten bucks you can have a brand new assembly, mine was about 22 bucks. its much easier working on a bike when the dam shutoff valve works! :thumbsup:
 

·
Registered
Joined
·
2,786 Posts
Maybe your drainage screw is loose...
 

·
Registered
Joined
·
1,568 Posts
dan6782 is more than likely right, a sticking float valve will continue to let fuel in and it will over flow out of the over flow tubes. More than likely it needs taken apart and cleaned, and check the float height on each carb.

sometimes that spec of dirt will hold the valve open, othertimes it will break loose be fine for awhile and get stuck again, so it doesn't happen all of the time but it happens consistantly. One second your carbs are fine the next one of them is pooring gas out of the overflow tubes..
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #5 ·
Thanks guys. I thought this was it. I'll work on this weekend.
 

·
Registered
Joined
·
50 Posts
Discussion Starter · #7 ·
Done!! Cleaned it and it works perfect again. Thanks Guys!!!!!!!!!

Love this site!!!!

Dvlracer!! Just clean it like I did and it will be fine. I really can't answer the popping and small backfire at WOT though. Sorry dude....
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top