Raptor Forum banner
1 - 20 of 22 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter · #1 ·
Okay, so new to the site, thought id see if you guys could help me out with this one. I have a 2003 raptor 660r. The carb is spotless. Can't find any air leaks. Cleaned wire going to coil. I have disabled both pb and reverse rev limiters. Pb by cutting the wires at the switch on the handle bars. Disabled the rev by cutting the red wire coming from the stator. It will start, and idle perfectly. But when I try to drive it will only rev up to about 1/3 throttle the sputter like the rev limiter is on but if I full choke it and pump the throttle quickly I can get it past the sputter point. Which leads me to believe its not electrical. I have tried adjusting the needle clip too. No dice. Just cannot figure this thing out.
 

·
Master of the Electron
Joined
·
15,622 Posts
Welcome to the forum. It's carbs not carb and you most likely have a carb problem.

What are your mods, your main jet sizes, pilot jet sizes, needle type and settings, and fuel screw settings?
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #3 ·
Thanks for the welcome. The carbs have new carb kits in them that was all stock. I took note of what came out of them and they we stock as well. The only mod I can find that's been done to it is a k&n filter.
 

·
I am unique
Joined
·
22,621 Posts
Thanks for the welcome. The carbs have new carb kits in them that was all stock. I took note of what came out of them and they we stock as well. The only mod I can find that's been done to it is a k&n filter.
And fuel screws are 2 1/4 left and 2 3/4 right.
Yiu didnt look at the numbers on the pilots, stock is 22.5 but you should install #25s and is your air box stock, or did you modify it at all, if you did you may need aftermarket needles, so start with a list of mods and your jet sizes...............
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #6 ·
The k&n filter is the only mod. Air box is stock. No holes, still has lid on it. But the pilots should be 25 instead of the stock 22.5?
 

·
I am unique
Joined
·
22,621 Posts
The k&n filter is the only mod. Air box is stock. No holes, still has lid on it. But the pilots should be 25 instead of the stock 22.5?
Yes use the 25s Does it still have the snorkel on the air box.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #9 ·
Hey thanks for your help. I got rid of the problem but now have another. The bike starts and idles fine, accelerates perfectly but if I'm put on the road in 5th gear going about 85 k/h it will drive perfectly for about 30 seconds at that speed then it will lose power and start popping on deceleration. Then i slow back down to 50-60 in 4th and cruise and all the power comes back. I thought it might be the float level being too low and it's running out of gas? Just going to do clear tube method now but I thought I'd ask your opinion. Thanks.
 

·
I am unique
Joined
·
22,621 Posts
Hey thanks for your help. I got rid of the problem but now have another. The bike starts and idles fine, accelerates perfectly but if I'm put on the road in 5th gear going about 85 k/h it will drive perfectly for about 30 seconds at that speed then it will lose power and start popping on deceleration. Then i slow back down to 50-60 in 4th and cruise and all the power comes back. I thought it might be the float level being too low and it's running out of gas? Just going to do clear tube method now but I thought I'd ask your opinion. Thanks.
Sounds like you are running out of fuel at the float bowls. This could be caused by a dirty petcock filter.........
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #11 ·
Okay thanks I'll check that out too. I just did the clear tube test and the left side was 4 mm and the right side was 3 mm.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #12 ·
Just checked the petcock. The res filter is ripped open quite a bit. The on position filter is missing, just a straight pipe.
 

·
Master of the Electron
Joined
·
15,622 Posts
I'd suggest adding an in-line filter with the supply tubing, then nothing will get into the carbs.

So the petcock filter isn't slowing flow down, but perhaps gunk has reached one or both float valve in the carbs, slowing flow through that valve - this will cause the level in the bowl to drop as you run at WOT, and it will get lean, as you describe.

Check your float valves for obstructions in the seats.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #14 ·
Okay, so I added and in line filter, and the fuel line that was on the bike was clear, very flexible tubing. It was kinked near the carb restricting flow there. So I pulled the carbs, cleaned them thoroughly and replaced the clear line with thicker black fuel line. Not kinked now. Should be good now. I will find out tomorrow. Thanks for your help.
 

·
Master of the Electron
Joined
·
15,622 Posts
Yes, a kink in the fuel line could well have caused your symptoms... good find.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #16 ·
Okay so after the carb cleaning and new filter and fuel line it still does it. I'm stumped. Only does when i have it going full out in 5th. Runs mint otherwise. It's my first raptor and I love it. I had it going 127 k/h on gps. Is this normal top speed or should it be faster? Also have any other ideas of what I could check that might be causing this problem? Thanks
 

·
I am unique
Joined
·
22,621 Posts
Okay so after the carb cleaning and new filter and fuel line it still does it. I'm stumped. Only does when i have it going full out in 5th. Runs mint otherwise. It's my first raptor and I love it. I had it going 127 k/h on gps. Is this normal top speed or should it be faster? Also have any other ideas of what I could check that might be causing this problem? Thanks
You are hitting the high speed rev limiter. A way to bypass this is to remove a bunch of teeth from the rely got wheel at the sensor.
 

·
Registered
Joined
·
14 Posts
Discussion Starter · #18 ·
Okay I didn't know the rev limiter acted like that. Thought it was a fuel restriction. What about the speed? Is that a normal top speed for it?
 

·
I am unique
Joined
·
22,621 Posts
Okay I didn't know the rev limiter acted like that. Thought it was a fuel restriction. What about the speed? Is that a normal top speed for it?
That is about the right speed for the limiter to engage.
 
1 - 20 of 22 Posts
Top