Raptor Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Starts and runs great but will not shut off. It will start and run if the handle bar switch is off and the key is off.??? Switched out CDI with a known good one, and replaced ignition switch with a new one. Not sure where to go to next. Anyone have any ideas?

Thanks,
Tom
 

·
I am unique
Joined
·
22,621 Posts
Starts and runs great but will not shut off. It will start and run if the handle bar switch is off and the key is off.??? Switched out CDI with a known good one, and replaced ignition switch with a new one. Not sure where to go to next. Anyone have any ideas?

Thanks,
Tom
Check the wiring harness, you must have a short between your red and brown wire..............
 

·
Master of the Electron
Joined
·
15,685 Posts
More than just that, the brown to red/black is shorted also, else the run/stop switch would work...

I'm going to bet that a previous owner re-wired the CDI and provided 12V directly to the red/black wire when he couldn't figure out something else that was wrong.

I'm also going to guess that you just got this quad, right?

Else, your short is most likely between red and red/black. Measuring with a voltmeter will tell you what's going on.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
Did a continuity test between the red and brown. All is good there. Yes, I just got this quad, gonna head out to the garage and check out the red and red/black. Thanks for the input guys!!!
 
1 - 4 of 4 Posts
Top