Raptor Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
ok so me and a buddy just got a 03 660 with a 686 kit, full exhaust, and a k+n... the problem is it wouldnt start when we got it so we took it to the local shop. guy put new battery, new relay, new starter, adjusted the valves, and cleaned the carbs. he did all the work on my last raptor as well, so i trust the guy... were plannin on riding trip tomorrow but when we start the quad it idles a little funny and when you hit the throttle it backfires like a m16...any idea?
 

·
Registered
Joined
·
74 Posts
carb issue sounds like its lean? does it work better with choke on a little? if so its your carb or maybe fuel line is clogged and fuel shut off valve plugged off? first thing to try take fuel line off and see if fuel comes out in nice stream if not take tank off its plugged or if thats ok carb issue? let me know what you find
 

·
I am unique
Joined
·
22,621 Posts
ok so me and a buddy just got a 03 660 with a 686 kit, full exhaust, and a k+n... the problem is it wouldnt start when we got it so we took it to the local shop. guy put new battery, new relay, new starter, adjusted the valves, and cleaned the carbs. he did all the work on my last raptor as well, so i trust the guy... were plannin on riding trip tomorrow but when we start the quad it idles a little funny and when you hit the throttle it backfires like a m16...any idea?
Most likely the park brake sensor is stuck on, or is on............
This turns on the park brake rev limiter...........
 

·
Registered
Joined
·
23 Posts
Discussion Starter #4
So say we have two other buddies that know everything and they ripped off the parking break yesterday and put on a block off plate....how do I go back and fix it
 

·
I am unique
Joined
·
22,621 Posts
So say we have two other buddies that know everything and they ripped off the parking break yesterday and put on a block off plate....how do I go back and fix it
Unplug the park brake switch from the harness, just follow the wire to the main harness and unplug it, also seal it, any moisture or mud that enters that connector, can turn on the park brake rev limiter.........:)
 

·
Git-R-Done
Joined
·
729 Posts

·
Git-R-Done
Joined
·
729 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #9
Holy crap....this is awsome....thanks guys your like Santa clause at Christmas time....but better!!! Unplug that sensor and she's perfect...thanks again
 

·
Git-R-Done
Joined
·
729 Posts
Good to here, now go ride......
 

·
Master of the Electron
Joined
·
15,065 Posts
Doesn't ANYBODY ever read the stickies anymore? ESPECIALLY - "Most common 660 problems"?
 
1 - 11 of 11 Posts
Top