Raptor Forum banner
1 - 20 of 56 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter · #1 ·
04 660 brand new carbs stage 2 exhaust and k&n filter. Ran this summer. It’s not starting. Reverse limiter is not the issue. Plug is new.

I don’t know where my choke, throttle and air screw suppose to be adjusted too. It kinda pops and sometimes backfires once. If it does start it will idle high with choke on and then idles down and shuts off. I have never had any issues until I messed with the settings.
Automotive tire Hood Vehicle Motor vehicle Automotive design
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #2 ·
It did sit in my shed for 3 months could it have got condensation in tank possibly?
 

·
Registered
Joined
·
175 Posts
You need air. Back off that throttle cable adjustment screw about 1/4" and see how that treats you.

Hood Vehicle Automotive tire Car Motor vehicle
 

·
Registered
Joined
·
175 Posts
Ok I will try that. How about choke?
Choke to start if needed. Keep choked to maintain roughly 1500-1800rpm, reducing choke as necessary until it's fully off and you're idling at said rpm. Adjust the throttle screw as needed.
 

·
Registered
Joined
·
2,553 Posts
It did sit in my shed for 3 months could it have got condensation in tank possibly?
I doubt it, but that is certainly long enough to gum up a pilot jet which would cause starting/idling issues. Especially if the fuel is not top quality

Sent from my SM-G981U using Tapatalk
 

·
Registered
Purple 2003 Raptor 660, White 2001 Raptor 660, Arctic Camo 2008 Raptor 250.
Joined
·
122 Posts
That'll do it. I just had the same issue. I drained the fuel out of the carbs (A tiny screw under the carbs) and ran some seafoam through it, and it cleared right up. If it still doesn't clear up, take the carbs off and give them a cleaning. Next time when you put it away, turn the fuel off and run it until it shuts off and drain the carbs after that.
 

·
Registered
Joined
·
32 Posts
Discussion Starter · #12 ·
I pulled the carbs which are brand new not it even an hour of run time. Changed plug other one was charcoaled. Clean spark plug boot, cleaned parking brake sensor and cleaned the reverse limiter connector. Starts up with choke revs up pops and spits. Disconnected parking no change. Disconnected reverse limiter no change. Even with choke about off it will idle down and pop and backfire. Also I am seeing the reverse light flashing. What can I try next. Also thanks about running it empty when I put it away. Video of it running sorry it’s short but you get idea.
 

·
Registered
Purple 2003 Raptor 660, White 2001 Raptor 660, Arctic Camo 2008 Raptor 250.
Joined
·
122 Posts
whoops I fixed it its public now.
It reminds me of my TTR230, and that has carb issues that I still haven't dialed in yet. Is your jetting off potentially? That is the only thing I can think of if you still have all your parking brake limiter and reverse limiter off. Maybe someone more experienced in carbs can jump in. lol.
 

·
Registered
Joined
·
3,611 Posts
Carbs are new and have stage 3 DJ. Ran good 3 months ago same set up.
New oem factory carbs?
Or ebay amazon china carbs?
Because if you have chinese carbs, that is the first problem.
From there jettings and settings are incorrect.
Read the 660 Stickies, all the carb info is in there.
 

·
Registered
Joined
·
12 Posts
04 660 brand new carbs stage 2 exhaust and k&n filter. Ran this summer. It’s not starting. Reverse limiter is not the issue. Plug is new.

I don’t know where my choke, throttle and air screw suppose to be adjusted too. It kinda pops and sometimes backfires once. If it does start it will idle high with choke on and then idles down and shuts off. I have never had any issues until I messed with the settings. View attachment 142367
I had the same problem, mine was the cdi box
 
1 - 20 of 56 Posts
Top