Raptor Forum banner

1 - 4 of 4 Posts

·
Master of the Electron
Joined
·
15,442 Posts
Discussion Starter · #1 ·
Bought an '02 3 weeks ago. Replaced the one-way with an L&R and then did full basic service: oil, coolant, valve adjust, lube the zerks, new irridium plug, clean and fix every noticeable problem. It came with CT Racing pipe, jets, K&N filter, no lid.

First ride last weekend. Very nice but for one issue. 0 - 1/4 throttle is great. 3/4 to WOT is FANTASTIC!

BUT, between 1/4 and 3/4 throttle it stumbles/hesitates/hunts. Not smooth at all, difficult to ride. Sounds like needle jet/needles, right? No backfires on or off throttle. I'm guessing that it's rich and so lower the needles (raise the clip a notch). Does this sound like the proper course?

Also, the choke seems to have no impact on or off, cold or warm at idle. Is it possible that the enrichment circuit is on all the time? I dont' see how this would affect mid throttle range only, but???? Any ideas?

It has always been at near sea level, no change in altitude. I cant test at home (neighbors) so i'd like to figure this out in as few trips to the desert as possible. If i cover most of the airbox opening (restrict the inlet) with cardboard and duct tape, will this tell me about operation if i leaned it out, or would that richen it ? thought that might be a good way to troubleshoot at my next ride.

Any help/suggestions are greatly appreciated.
 

·
Registered
Joined
·
8 Posts
go down a little further and read my post.........rt's suggestion to me took care of my problem...my post was hesitating raptor.
 

·
Master of the Electron
Joined
·
15,442 Posts
Discussion Starter · #3 ·
Thanks! I saw your post, but felt that my problem was manifesting itself at a different throttle position - mine's definitely 1/4 to 3/4, and i have no backfires. BUT after reading it again, it might just be the thing.
I will give it a try. And, it's an easy thing to tweak when i'm out riding. That's a plus!
 
1 - 4 of 4 Posts
Top