Raptor Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I was driving my 660 raptor 2005, and suddenly my throttle was stoppinh and coming back on, which started after i put in 95 octane fuel, anyway then today i noticed that everytime the throttle shuts down my reverse light pops on, and when it goes back off i have control again. anybody have any idea what is causing this? I was going to use it this weekend but with this its undrivable.
 

·
Registered
Joined
·
1,516 Posts
I don't know where or how it's detected on a 660, but it's probably the reverse switch kicking in when it shouldn't. This turns on the rev-limiter on the engine so if you're going anything over a slow rev it will kick in.

On the 700 there's a sensor on the transmission near the sprocket... It has tiny and quite fragile wires.
 

·
I am unique
Joined
·
22,619 Posts
I was driving my 660 raptor 2005, and suddenly my throttle was stoppinh and coming back on, which started after i put in 95 octane fuel, anyway then today i noticed that everytime the throttle shuts down my reverse light pops on, and when it goes back off i have control again. anybody have any idea what is causing this? I was going to use it this weekend but with this its undrivable.
Fix the connection at the reverse switch by the drive sprocket. Green and white wire
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Well before all this the reverse light didn't even go on, so now it suddenly decides to act up but closes down the throttle, i shall check the wires and see what ill find. hopefully i don't need a new sensor.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
okay so I started it up and now my reverse light stays on the whole time, I played with my wires and nothing seems to make it turn off.. could my switch be stuck or something? I see no wires coming from the switch whatsoever and its a metal cord, where do my wires come out of the engine that control that stuff?
 

·
I am unique
Joined
·
22,619 Posts
okay so I started it up and now my reverse light stays on the whole time, I played with my wires and nothing seems to make it turn off.. could my switch be stuck or something? I see no wires coming from the switch whatsoever and its a metal cord, where do my wires come out of the engine that control that stuff?
Ground the green and white wire at the Cdi.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
where is the cdi? im a bit new to this, I have found the green and white wire and followed it down its hanging loose.. an d if I unplug the connectors my neutral light goes out but the reverse thing still persists. its definitely a limiter that's messing things up, I appreciate your help. and also it was already grounded before the connection place, when I touch it nothing happens so im not sure what is wrong now.
 
1 - 10 of 10 Posts
Top