Raptor Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
273 Posts
Discussion Starter · #1 ·
Hey guys, my buddy just got his 700 in december. He said it revs but won't go very fast, it sounds like a smoked clutch but he does'nt even have 30 hours on it and he is pretty careful with it. Any ideas or similar problems. (it is under warranty) Thanks. :3question:
 

·
Registered
Joined
·
683 Posts
should be under warranty but
does he have too much oil in it ?
this may contribute to it slipping ..
and is it adjusted properly>?
may need to adjust the free play in the handle

I know Rocket factory is pounding the shit out of the stock clutch
and has not given out yet so for a stock or semi modded raptor to kill a clutch
don't sound right

I did upgrade my clutch for the big bore kit
but It has been proving that I didn't need too
 

·
Registered
Joined
·
273 Posts
Discussion Starter · #4 ·
Thanks hippy I'll ask him about his oil level. ;)
 

·
Registered
Joined
·
273 Posts
Discussion Starter · #5 ·
If anyone cares it was his clutch cable. He had to adjust it down by your right foot.
 

·
Registered
Joined
·
84 Posts
It's wise to check the adjustment of your cables every few rides. :beer:
 

·
Registered
Joined
·
84 Posts
Yeah sounds like the cable is too tight and not letting the clutch engage fully if you slacken it off next to your rear brake lever no tthe very end of the threads (more threads to the left none on the right) it will make sence when you look at it then take up the free play in the bar ajustment so you can keep on top of it while your riddin.
Hope this helps
 

·
Registered
Joined
·
54 Posts
my stock clutch was gone after about 30 hrs of dragging
 
1 - 11 of 11 Posts
Top