Raptor Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
207 Posts
Discussion Starter · #1 ·
i got the full exhaust in and the pro design set up and i went to install the dobeck gen 3 ,and i disconnected the stock fuel injector plug but the dobeck has 2 males which goes into stock plug? which female goes onto stock male? am i making this harder than it is? this dobeck has two male and two female with different wire combo's and directions do not cover much
 

·
Registered
Joined
·
17 Posts
Same issue, no directions with it at all. I shot emails out both companies. Will let you know if they reply to me.
 

·
Registered
Joined
·
207 Posts
Discussion Starter · #4 ·
chad,
i have these directions , it says" Unplug the connector at the injector.
*Plug the female connector in the Dobeck harness into the injector, Plug the make connector (the short pigtail on the Dobeck harness) into the stock connector you unplugged fron the injector" ok.....i have two females and two males on my dobeck does this mean i have the wrong one?it says for raptor 700 2006? how many plugs did yours come with ?
 

·
Registered
Joined
·
28 Posts
Something doesn't sound right - Mine had only one female and one male connector. Unfortunatly the optimizer itself has no model number on it. The only number I can find on my unit is the patent # 7,00,599. There are only four wires coming from the optimizer - red, white, yellow, and black in that order from left to right. The wires are on top of the unit on the right side. It almost sounds like they sent you one for a 07 Outlander 800.
 

·
Registered
Joined
·
207 Posts
Discussion Starter · #6 ·
thats it, i think the one they sent me is for a v twin bike because it has 2 of each male and female connectors
 

·
Registered
Joined
·
17 Posts
I have the exact problem as lovingmyraptor. I bought mine thru worldwideperformance, and they just order it from HMF. So far quite disappointed in the transaction; and especially after reading the chads great replies from HMF. I told them it was for a 2007 but they sent me the double set wire thing. Sounds like i am in for a battle with them,but clearly it is not for a raptor
 

·
Registered
Joined
·
17 Posts
Chad here is what was shipped to me. I am guessing lovingmyraptor got the same.

 

·
Registered
Joined
·
28 Posts
Not good, mine is completly different, only 4 wires come out of my box, it looks like you have 6 or more, that is not for a 700 raptor. I also only have one male and one female connector. HMF srews up again!!

The Optimizer itself looks identical, but there are way more wires.
 

·
Registered
Joined
·
28 Posts
Found some more information on tuning the Optimizer -thank GuamRaptor700. From the research I have done the Trinity Racing and HMF Optimizer are the same thing with different packaging. When you guys get the correct Optimizer here is the link:
http://www.raptorforum.com/index.php?topic=10263.0

Also if you guys can get your money back from the HMF and get the Power Commander, it seems like people have had much better luck with that model than what we have experienced. If not then the above link should help, it is way more information than HMF wanted to give me.

Thanks again GuamRaptor700, i finally think that I got the programming set.
 

·
Registered
Joined
·
119 Posts
that is definitely not the correct efi controller. i have white brothers version of the same exact controller. you should have 2 conectors and a black ground wire.

tuning them is very easy, if you understand what each setting is used for. 1-3 are the bottom, mid, top & 4-5 is for throttle response at different throttle positions. the instructions are very useful.
 

·
Registered
Joined
·
8 Posts
Sounds like Dobeck is having quality control issues. I have the same problem. The box says it is for a Raptor 06 but it has four connections. Makes you wonder how reliable the controller is.
 

·
Registered
Joined
·
28 Posts
Has anyone tried to run the Raptor with the 4 connector version by only plugging 2 in? Maybe they changed the design -doubtful but who knows. Don't try it if you haven't already, it may mess up the quad, but it was just a thought.
 

·
Registered
Joined
·
207 Posts
Discussion Starter · #16 ·
i have, it does not work using only two of the connections
 
1 - 16 of 16 Posts
Top