Raptor Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
815 Posts
Discussion Starter · #1 ·
hey guys - I just purchased the Vapor, xbars (black), and dashboard from steve at Techquadshop... he is great to do business with.. very helpful... great customer service...
- - on the VAPOR- is there anything i need to know before installing it ? ? I have read alot about ppl having problems... and certian wires to connect and not to connect.. and stuff like that...
- -so do you all have any suggestions for me - to make the install go smoothly... ? ? ?
is there anything that i need to know, that is not on the instructions ? ?

Thanks guys - i should have the Vapor on Wed, so i will probly install wed or thurs..
Aaron Plattner
 

·
Registered
Joined
·
815 Posts
Discussion Starter · #2 ·
- - oh and by the way - i did do a search first - but didnt find any specifics about installing problems or things to look out for...

thanks for your help guys - -its much appreciated
Plattner
 

·
Registered
Joined
·
815 Posts
Discussion Starter · #5 ·
Ya i figured someone would tell me to do a search. since thats what i always tell ppl... ha ha
Also woody - how do you like your case saver ? i need one... im not running one at all right now.. ha ha .

Plattner
 

·
Registered
Joined
·
1,938 Posts
I like it i guess.. :grin_nod: I just bought it because i seen what happen to a 450 motor that didnt have one. I bought mine form golden west cycles for like $20. it fits perfect with the 15t and 14t. pretty clean looking when all cleaned up. Would look even better on your if it was powder coated red.
 

·
Registered
Joined
·
259 Posts
Real easy install but if I had to do it over the only thing I would look for is to be sure you dont overtighten the nut that goes on the speed lead that connects to the c clamp. Also when you do your temp sensor make sure you cut a good straight peice of the hose to fit the sensor and be able to tighten the clamps. Cant help you out on the rpm cause there different on the 660's. Thats the only thing I had messed up on everything else is pretty straightfroward at least on the 660. Goodluck :thumbsup:
 

·
Registered
Joined
·
815 Posts
Discussion Starter · #10 ·
alright - thanks for the advice dberry.

bbreck - thanks for that link... that will be very helpfull... i thought i had remembered readin about doing a low voltage... glad you pointed that out...

woody - ya i think i am going to get a case saver like yours... and then when my buddy is shooting red again - i will have him throw it in.. ha ha

Plattner
 

·
Registered
Joined
·
4,785 Posts
Also the tach wire and the power wire look identical, but if you look close one will have a small resistor in it (about the size of a grain of sand) heat wrapped in black close to the end. Make sure you use the one with the resistor for the tach. My instructions made no mention of this, i found it here after I had them backwards lol :thumbsup:
 

·
Registered
Joined
·
2,127 Posts
its a pretty easy install.. just take ur time and make good cuts and nice routing of wires and follow directions and you should do just fine.. If you can to a head/piston/cam swap you will do just fine on this
 

·
Registered
Joined
·
1,678 Posts
Install is a breeze. Takes about 2 hours your first one. I helped a friend do his after mine and it took 45 minutes. Just plug the rpm into the coil instead of the wrap method, its more accurate and takes .5 seconds.
 

·
Registered
Joined
·
562 Posts
Lets see some pics when you are all done with the install.... :thumbsup:
 

·
Registered
Joined
·
815 Posts
Discussion Starter · #16 ·
I will definantly post some pics once i get it installed... this is something i have been wanting for awhile.. .so i pretty excited about it...
- - You say to plug the rpm into the coil instead of the wrap method - which way does the instructions say to do it ? ? just wondering if i need to vear off the instructions, or if the instructions are dead on..

Thanks for all the input guys... yea i figured if i could rebuild my motor, then i could do this... but this is electrical shit... i am good at electrical shit, but hate working with it. ahaha

Plattner
 

·
Registered
Joined
·
4,785 Posts
plattner said:
I will definantly post some pics once i get it installed... this is something i have been wanting for awhile.. .so i pretty excited about it...
- - You say to plug the rpm into the coil instead of the wrap method - which way does the instructions say to do it ? ? just wondering if i need to vear off the instructions, or if the instructions are dead on..

Thanks for all the input guys... yea i figured if i could rebuild my motor, then i could do this... but this is electrical shit... i am good at electrical shit, but hate working with it. ahaha

Plattner
The instructions that came with mine still showed the wrap method but the link to the instructions I gave you is the coil method. :thumbsup:
 

·
Registered
Joined
·
815 Posts
Discussion Starter · #18 ·
alright - thanks for your help...
so is there any splicing that has to be done ? ? sodering ? or is it all plug in connectors...

Plattner
 

·
Registered
Joined
·
4,785 Posts
1 wire direct to battery

1 wire to speed sensor

1 wire to Coil/ground

1 wire to temp sensor

No splicing but have cut a coolant hose and unplug a wire from the coil and jam a wire in it then replug and find a good ground. :thumbsup:
 

·
Registered
Joined
·
815 Posts
Discussion Starter · #20 ·
Alright techquadshop got me the Vapor, xbars, and dashboard, and spider grips.... i have been fighting the flood along the Missouri river, trying to save some of our farm land... so i havnt had time to install everything... but am planning on installing it this weekend, probly friday... i will post pics once im done... thanks again for all your help - i will be getting back on here if i have problems..

Aaron Plattner
 
1 - 20 of 20 Posts
Top