Raptor Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
53 Posts
Discussion Starter · #1 ·
Hey Guys,
So yesterday I was riding my bike and I pressed out in 5th gear and it started to cut fuel real bad making me have to let off. Then it seemed to ride okay once i stayed at lower rpms then as i continued riding it just got worse and worse and would occur in basically any gear at high rpms. It actually cut out a few times as well but started right back up. I managed to get home and just checked basic things, had a full tank of gas, EFI settings were accurate, and nothing that i could see seemed out of place.
Any ideas??
Current Mods: JE 11.1 compression piston, +5 HR crank, Hotcam Stage 2, DMC force 4 duals, Monster intake, and EHS racing EFI controller.
Thanks!
 

·
I am unique
Joined
·
22,621 Posts
Hey Guys,
So yesterday I was riding my bike and I pressed out in 5th gear and it started to cut fuel real bad making me have to let off. Then it seemed to ride okay once i stayed at lower rpms then as i continued riding it just got worse and worse and would occur in basically any gear at high rpms. It actually cut out a few times as well but started right back up. I managed to get home and just checked basic things, had a full tank of gas, EFI settings were accurate, and nothing that i could see seemed out of place.
Any ideas??
Current Mods: JE 11.1 compression piston, +5 HR crank, Hotcam Stage 2, DMC force 4 duals, Monster intake, and EHS racing EFI controller.
Thanks!
Does the 700 have a fuel filter, that would be the first thing I would check..............
 
1 - 4 of 4 Posts
Top