Raptor Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter · #1 ·
My starter/ starting system has gone goofy. I will be riding and the starter will randomly kick on, and sometimes for a few seconds. If I stop it will continue to stay on and the battery (or something by the battery) will eventually go click click. If i turn the key off and then on the starter will turn on again. Yet if I do this multiple times it will be normal (Maybe i shake it enough to cut out a short... if there is one)

Where should I start. Here is what I do know:
My battery has 12.88 volts.
My starter button is not sticky as far as i know.
Fuses look good.
Starter obviously works.
Oneway is original, but was in perfect condition four months ago.

Thanks in advance because this is beyond me lol. I am somewhat mechanically enclined not electrically. Please help!
 

·
Registered
Joined
·
4,134 Posts
So your starter is staying engaged?
 

·
Registered
Joined
·
2,121 Posts
Check your starter switch vmy 660 did this Put a new copper spring in it and it was fine.
 

·
Master of the Electron
Joined
·
15,524 Posts
You say that when the failure occurs, the starter can continue turning over even when the key switch is turned off? What about the run/stop switch? Next time it happens (assuming it happens often and readily), pull the fuse and see if it stops.
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #6 · (Edited)
QM I was not clear. It does stop when i turn off the key. But when I turn the key back on it will immediately start and the motor and starter will continue to run. If i cycle it on-off-on-off the starter will usually function normally.

This just started two weeks ago and has only happened about seven times.
Could this be a starter solenoid? Because before this started i noticed that it would click with the push of the starter button, and then it would fire with the next push. For all I know these two might not be related.
 

·
Master of the Electron
Joined
·
15,524 Posts
No, then it is DEFINITELY not the starter relay (solenoid). Check by turning the key switch on and setting the run/stop switch to stop (starter should not run now).

If this is correct, it's most likely the starter button switch shorting closed. Remove the left bar switch cluster and find/fix the issue... OR it could be (less likely) the blue/black wire from the start button to the relay with an intermittent short to frame or other ground, somewhere along it's path... I'd bet it's the switch, though.
 

·
Registered
Joined
·
87 Posts
Discussion Starter · #8 ·
Well I decided I should check the wires before I buy the solenoid and I am glad I did. The short was right where the wires pass by the plastic and steering column. it was rubbing on a bolt and nut. I fixed the short with some electrical tape and I put it back into the clip thingy thats supposed to hold them anyway.
Now it works fantastic! Thanks for the ideas QM!
 

·
Master of the Electron
Joined
·
15,524 Posts
Well, if you HAD bought the solenoid I woulda been upset, since I told you it wasn't the problem!

Glad you found it, and you did beat me on the bet (i bet it was the switch). Good job.
 

·
Registered
Joined
·
8 Posts
Starter Assistance - Bew to forum

Has anyone done a starter rebuild with kit like this off ebay http://www.ebay.com/itm/Starter-KIT...Parts_Accessories&hash=item414cc2a102&vxp=mtr

or purchased this new starter from ebay http://www.ebay.com/itm/NEW-Yamaha-...Parts_Accessories&hash=item3f064fa2b3&vxp=mtr

Purchased a 04 Raptor 660 that had been setting for 2-3 years. Starter is engaging although not turning engine over with new battery. All wiring appears to be in good condition. Thoughts are most likely starter internals are corroded from moisture.

Agreements on assumption starter is issue if so place to buy good rebuild kits or new starter would be appreciated.

Thanks
 

·
I am unique
Joined
·
22,621 Posts
Has anyone done a starter rebuild with kit like this off ebay http://www.ebay.com/itm/Starter-KIT...Parts_Accessories&hash=item414cc2a102&vxp=mtr

or purchased this new starter from ebay http://www.ebay.com/itm/NEW-Yamaha-...Parts_Accessories&hash=item3f064fa2b3&vxp=mtr

Purchased a 04 Raptor 660 that had been setting for 2-3 years. Starter is engaging although not turning engine over with new battery. All wiring appears to be in good condition. Thoughts are most likely starter internals are corroded from moisture.

Agreements on assumption starter is issue if so place to buy good rebuild kits or new starter would be appreciated.

Thanks
If the starter is turning and the engine isn't then your problem is the oneway clutch behind the flywheel.
 
1 - 11 of 11 Posts
Top