Raptor Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
197 Posts
Discussion Starter · #1 ·
My family and I went over to white wash sand dunes near moab and the only machine to break down was my rappy :rolleyes: It ran really strong but the cylinder came loose haha. Nothing happened besides leaking oil at the bottom of the cylinder luckily. I torqued everything to specs but I guess this time I am going to loctite the shit out of it. Has anybody else had this happen to them? I will get a couple of videos up but there isn't any of the the 660.
 

·
I am unique
Joined
·
22,621 Posts
My family and I went over to white wash sand dunes near moab and the only machine to break down was my rappy :rolleyes: It ran really strong but the cylinder came loose haha. Nothing happened besides leaking oil at the bottom of the cylinder luckily. I torqued everything to specs but I guess this time I am going to loctite the shit out of it. Has anybody else had this happen to them? I will get a couple of videos up but there isn't any of the the 660.
Make sure you have the cylinder bolts in the right place, the bolts with the dots go to the cam chain side.......
You dont need loctite...............when properly torqued............;)
 

·
Registered
Joined
·
197 Posts
Discussion Starter · #3 ·
I haven't heard about that before. I will make sure that I do that and I think I will still use a little loctite just to be safe. I remember reading somewhere about removing a layer or two from the base gasket to get more compression. How much compression would I gain from that?
 

·
Registered
Joined
·
197 Posts
Discussion Starter · #4 ·
Ok well I got it apart and this is what I found. I thought it was weird because the other cylinder bolts were fine, it was just the back left (when you are sitting on it) bolt. Time for some helicoil!
 

Attachments

1 - 4 of 4 Posts
Top