Raptor Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,740 Posts
Discussion Starter · #1 ·
My 700R will not start and while turning over it backfires!

Any suggestions will be greatly apprecaitive.

One person said that if the EFI System experiences a quick change in temperatures, the EFI Freaks out...is this true?
 

·
Registered
Joined
·
44 Posts
its prob like spark plug like he said i had that some problem today started up ran for couple secs then died tryed it again all it did was backfire and not start changed the plug and then bam i kicked it up a notch and it ran bettter then it did
 

·
Registered
Joined
·
36 Posts
I had that happen once to mine. I just replaced the plug and started right up and ran fine. I always let mine warm up for a couple of minutes in the winter b/c I think that was the culprit.
 

·
Registered
Joined
·
9 Posts
I concur on trying a new plug. I just had the same issue with mine and a new plug fixed it.
(Man these things are LOUD when they backfire)
 

·
Registered
Joined
·
1,885 Posts
I was in a warehouse when my raptor's plug fouled and it backfired! My ears rang for that day........
 

·
Registered
Joined
·
1,176 Posts
Check the plug first. (Never gas it when the engine is cold. The cold start enrichment will foul the plug)
Check the valve lash if that doesn't take care of it.
 

·
Registered
Joined
·
84 Posts
Changing the plug should fix it. If you have old fuel that may have moisture in it can give you problems too.
 

·
Registered
Joined
·
101 Posts
check the valves
 
1 - 9 of 9 Posts
Top