Raptor Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
My 05 Raptor 660 will not start. I had been riding for about an hour and then i stopped and it just cut off. I tried restarting in immediately but nothing. The lights wouldnt come on and i made sure all the battery terrminals were connected good. All it would do is i could here a click from under the seat. But i had my friend pull me and i dropped it in first and it started like that. So idk if its battery or someone told me posssible the one way bearing??
HELP!! :wow:
 

·
Git-R-Done
Joined
·
729 Posts
It sounds like your starter relay might be bad.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #3 ·
Thank You. Im going to put a battery booster on there today and make sure its not the battery. So if that doesnt work then ill look into the starter relay!
 

·
Git-R-Done
Joined
·
729 Posts
Welcome to the forum!!!!! Try to short across the two large lugs on the relay with a screwdriver or pair of pliers (ignore the sparks). Does the starter turn over now? if it does then i would replace the starter relay.
 

·
Premium Member
Joined
·
3,166 Posts
if it doesn't it might be the brushes in your starter. LIGHTLY tape the starter with a hammer while holding the start button. if it starts that way you need new brushes
 

·
Master of the Electron
Joined
·
15,629 Posts
If your lights also wouldn't come on, it's battery, battery connections or fuse related (could be key switch also).

If it starts with a battery box, it's most likely battery... but clean the battery connections anyway.
 

·
Registered
Joined
·
55 Posts
I believe it is the battery, that happened to mine and I jump started it and it crunk right up.
 

·
Registered
Joined
·
55 Posts
o and since it cut off and the battery was dead, it could be your recifier, check that too!
 

·
Premium Member
Joined
·
4,191 Posts
I believe it is the battery, that happened to mine and I jump started it and it crunk right up.
Hahahahaha I'm sorry, I don't mean to laugh, but this had me rolling for some reason. "Jump started it and it..." DID WHAT?
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #10 ·
Thanks guys! It was the battery, i got a jump box and it fired right up. Preciate the help!
 
1 - 10 of 10 Posts
Top