Raptor Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter · #1 ·
i cant keep my raptor running i have to give it half throtle for it to stay running when i let off the gas it dies out it seems to me that its not getting fuel i checked the fuel pump but its not the problem i hear it turn on. i cleaned the airfilter and the spark aresstor and thats when i had the problem. if anyone has any thoughts or ideas im open for anything!!! i dont know how else to explain it any better
 

·
Registered
Joined
·
22 Posts
sounds kinda similar to the problems I'm having. My bike would die at periodic times. Right now it won't even start. You might try giving rocket factory a call. They are really helpful and don't seem to mind answering questions like these. I would start with the easy things. Check your spark plug. You can crank the bike with the spark plug out and watch the spark. If it looks good, then rule that out. And it probably is. Be careful not to get shocked. Shut the bike down and ground the spark plug against the frame before you let go of the plug. I'm starting to believe that some of these bikes have electrical problems. You can also take a volt meter and check your battery voltage at about half throttle. At 5000 rpm, you should see a rise in voltage and yours is probably fine, but see what the voltage is with it at idle. You may have a charging problem. A lot of people are replacing batteries and spark plugs and curing their problems. Sounds suspicious. I don't think it's your fuel pump. If your fuel pump works at higher rpms, it probably does fine at idle. Rocket factory claims that standing your bike up can cause problems, but I have never done this with mine, so I'm not sure what the fix is. Maybe drain the fuel out of the throttle body due to flooding. Good luck
 

·
Registered
Joined
·
226 Posts
Discussion Starter · #3 ·
Thanks man i gave up and took it to the shop ill post when i find the problem to let ya know. Good luck with your bike sounds like lots of raptors have electrical problems ive got faith in the shop i took it to. hope they find the problem!
 

·
Registered
Joined
·
497 Posts
it could be a couple things
faulty spark plug
faulty ECU
Faulty crankshaft positon sensor
improperly ajusted valve clearance
idle screw
 

·
Registered
Joined
·
648 Posts
Could it also be a faulty TPS?
 

·
Registered
Joined
·
226 Posts
Discussion Starter · #7 ·
Still not sure havent heard any thing from the shop they cant get to it till next week :(
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top