Raptor Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
229 Posts
Discussion Starter · #1 ·
Ok, SO I posed this before and listened to all the advice. Still not working right. My 350 when at high rpm even when under load is making a clicking (pop) noise from the engine randomly every 2-3 seconds. I pulled the air cleaner to see if I clogged it with my hand will it stall (yes) but every time the engine is making the clicking (pop) noise I noticed a puff of exhaust fumes was getting pushed out into the air intake. The only thing it does not make this noise when the choke is on and runs normal and choke works fine.

I rebuilt the carb got new jets float etc, new plug, new gas- even took the carb off again and cleaned the brand new jets with air. Not sure what else could cause this? Any Ideas?

 

·
Registered
Joined
·
49 Posts
Do you have a aftermarket aircleaner or slip on exhaust?? If you do you would need to rejet your carb...popping thru the revs and intake and exhaust is signs of running lean..I had the same problem changed my main to 152.5 can't remember my piolet size it runs great no more popping soo yeah hope this helps
 

·
Registered
Joined
·
229 Posts
Discussion Starter · #3 ·
its completely stock. Waiting to fix my current issues before i start tinkering.

Smoke out of the carb leads me to believe it could be the valve but then why doesn't it do it when the choke it on?
 

·
I am unique
Joined
·
22,621 Posts
I hear the clicking sound, does this sound like it is coming from the stator area of the engine.................
The stator and flywheel control the timing through the cdi, this could explain your missfire or the engine slowing down and the smoke from the arbs if there is something going wrong with the stator and or flywheel, such as part colliding in that area..........pull the stator cover and see...............
 

·
Registered
Joined
·
229 Posts
Discussion Starter · #5 ·
It seems more the stator area than the engine but I really cant pin point exactly where. I will pull the cover and look.
DO you think I can rule out a valve adjustment because it is not doing it with the choke on?

thanks
 

·
I am unique
Joined
·
22,621 Posts
It seems more the stator area than the engine but I really cant pin point exactly where. I will pull the cover and look.
DO you think I can rule out a valve adjustment because it is not doing it with the choke on?

thanks
VAlves wouldnt do that.
 

·
Registered
Joined
·
229 Posts
Discussion Starter · #7 ·
could not find anything loose around the flywheel stator area.... this is becoming a headach. the thing that gets me it the fact its only doing it when the choke is off. this has taken a few of the troubleshooting ideas i had to try to fix this?

Anyone have any ideas???
 

·
I am unique
Joined
·
22,621 Posts
could not find anything loose around the flywheel stator area.... this is becoming a headach. the thing that gets me it the fact its only doing it when the choke is off. this has taken a few of the troubleshooting ideas i had to try to fix this?

Anyone have any ideas???
Okay so give us a list of the stuff you have checked and or repaired in attempt to remedy your problem,
I here the clicking sound in your video, it has a missfire, at about the same time, I can go on a wild tangent here and suggest that because you are causing an extreme rich mixture here that somehow clears the problem and suggest that maybe you have a vacuum leak, a bad spark which the rich mixture causes the problem to disappear, or a problem with the stator having loose towers or a magnet in the flywheel being loose, etc...........Im not able to see the internals of the engine or not there to diagnose so you are my eyes and ears................
 

·
Registered
Joined
·
229 Posts
Discussion Starter · #9 ·
I hear ya. I checked the new plug and it looks more rich than lean this is the weird thing.
. Made sure that all carbclips where tight too. Thought a new boot but they all look good. No. Exhaust leak....
 

·
Registered
Joined
·
229 Posts
Discussion Starter · #10 ·
Ok so I actually brought it to the shop. The guy at the shop said that the popping is caused by the diaphragm flapping around when not under load which is causing the gasses to be forced out the carb. His explanation which I am having trouble remembering made sense as to why this is happening.

But just to bring closure to the situation. When you keep your throttle steady at a high RPM on a does it kind of pop and clank a little from the carb? (07 or newer or when ever they started the new model carbs on the 350)

Thanks,
 

·
I am unique
Joined
·
22,621 Posts
Ok so I actually brought it to the shop. The guy at the shop said that the popping is caused by the diaphragm flapping around when not under load which is causing the gasses to be forced out the carb. His explanation which I am having trouble remembering made sense as to why this is happening.

But just to bring closure to the situation. When you keep your throttle steady at a high RPM on a does it kind of pop and clank a little from the carb? (07 or newer or when ever they started the new model carbs on the 350)

Thanks,
Not all of these bikes do this. I have worked on few and never seen what you are talking of but I have seen it on the 450 YFZs.
 
1 - 12 of 12 Posts
Top